Opened 10 years ago

Closed 7 years ago

#1943 closed defect (fixed)

Missing timezones in Sugar Control Panel

Reported by: Clytie Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: timezone, missing, i18n
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

G'day :)

I just got my loan XO (to support our Vietnamese localization), and found I can't set my timezone in the Sugar Control Panel.

CST Australia (Adelaide) is UTC+0930, with Daylight Saving UTC+1030. The timezone list in the Sugar Control panel only has +0900 and +1000.

Interestingly, searching tickets here for "timezone" found bug #6 which reported the same problem in this tracker. The bug is labelled "Fixed", but when I registered with this tracker, I still found that the timezone list in Preferences only had UTC+0900 and UTC+1000. As far as I could see, there were no half-hour timezones, either here or in the Sugar Control Panel.

Why not use tzdata from Debian? I translate that, so I know it's up-to-date.

I hope I'm reporting this in the right place. I asked on #olpc-help.

Sorry, I can't input the Sugar version, because the XO's battery just died on me again. It's an XO-1, just sent by the OLPC contrib. team, so most likely pretty current.

I'll probably be back: we have critical input problems with Vietnamese on the XO. If I can't just edit the keymap (if I can find the dratted thing), I'll need to bother you again.

BFN :)

Clytie
Vietnamese Free-Software Translation Team

Change History (1)

comment:1 Changed 7 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

Adelaide is available as a option in the control panel "Date and Time" panel.

Looks like we are using a system list.

Closing as fixed, reopen if needed.

Note: See TracTickets for help on using tickets.