Opened 10 years ago

Closed 10 years ago

#1934 closed defect (fixed)

Speak-14 doesn't launch

Reported by: cjb Owned by: alsroot
Priority: High Milestone: Unspecified
Component: Speak Version: Unspecified
Severity: Major Keywords:
Cc: quozl Distribution/OS: Unspecified
Bug Status: Needinfo

Description

Reported by Yioryos Asprobounitis on the OLPC devel list:

I guess something was left out from the Speak-14 installation in this build.
Launching gives the following warning
"Cannot find cached 0sugar-launch implementation"
Tries for some more time and then dies.
Was fine in os116.

Attachments (1)

SL1934-speak-14-find.txt (62.4 KB) - added by quozl 10 years ago.
list of files present in the /home/olpc/Activities/Speak.activity directory

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by alsroot

  • Bug Status changed from Unconfirmed to Needinfo

Does Speak-14 from ASLO work?

comment:2 Changed 10 years ago by quozl

No, Speak-14 from ASLO does not work either. (Method used was to erase Speak from the laptop, then install it from ASLO).

No additional detail revealed on a manual sugar-launch.

Changed 10 years ago by quozl

list of files present in the /home/olpc/Activities/Speak.activity directory

comment:3 Changed 10 years ago by dsd

The OLPC build system downloads from aslo anyway, there's no other source of the download

comment:4 Changed 10 years ago by quozl

The activity log file is empty.

An strace shows a stat(2) of:

/home/olpc/Activities/Speak.activity/.0sugar/implementations/sha1new=3a08d5e9cc9efa3f425945b9eab8a451e804a131/0sugar-launch

and a subsequent failure of which(1):

which: no 0sugar-launch in (/home/olpc/Activities/Speak.activity/bin:/usr/local/sbin:/usr/sbin:/sbin:/usr/kerberos/sbin:/usr/kerberos/bin:/home/olpc/Activities/Terminal.activity/bin:/usr/bin:/bin)

The implementation of 0sugar-launch is present as ./.0sugar/implementations/sha1new=f1b4b919f86ff2687e181b3bf1671564412b86a2/0sugar-launch which is a different hash to what was probed.

The 3a08d5 hash is found in /home/olpc/.cache and removing this directory is a workaround. Speak starts correctly.

The contents of .cache appear normal.

comment:5 Changed 10 years ago by quozl

  • Severity changed from Blocker to Major

comment:6 Changed 10 years ago by quozl

  • Cc quozl added

Severity lowered because OLPC has a viable workaround, which is to include Speak-11 in the build. We'd still much prefer to include Speak-14 or later.

Supplied my .cache to alsroot on #sugar.

Another report of similar problem with Record activity on build 140py was seen on mailing lists.

comment:7 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

Issue was fixed in v15, 0sugar will not use shared 0install cache until more complex solution is accessible, like Saccharin sugar distribution.

Note: See TracTickets for help on using tickets.