Opened 10 years ago

Closed 9 years ago

#1931 closed defect (fixed)

Record 66-poor video with no sound

Reported by: mavrothal Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Record Version: 0.84.x
Severity: Major Keywords:
Cc: dsd Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

XO-1.5, os119, firmware q3a35, sugar 0.84.15, Record.activity-66.
Recording a video (low quality) takes ~30sec to start recording. Records a video with no sound (mic light does not come up) and needs more than a minute to process a 10sec video that plays very poorly.
Audio-only recording and picture taking is OK.
Log is attached

Attachments (2)

org.laptop.RecordActivity-1.log (14.4 KB) - added by mavrothal 10 years ago.
glive.py.patch (990 bytes) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (14)

Changed 10 years ago by mavrothal

comment:1 follow-up: Changed 10 years ago by cjb

I don't know what's up with the sound, but for quality I recommend that the default quality setting in Record be moved from "Low" to "High" -- the low quality recordings are incredibly pixelated and hard to watch.

comment:2 in reply to: ↑ 1 Changed 10 years ago by mavrothal

Replying to cjb:

I don't know what's up with the sound, but for quality I recommend that the default quality setting in Record be moved from "Low" to "High" -- the low quality recordings are incredibly pixelated and hard to watch.


Indeed High quality works better (maybe set as the default in XO-1.5 builds instead of Low?).
However, sound is recorded only for the first 1-2 sec of the clip. Then the clip is going silently.
Certainly not even close to the F9/Sugar0.82 version and far from usable.

comment:3 in reply to: ↑ description ; follow-up: Changed 10 years ago by alsroot

Replying to mavrothal:

XO-1.5, os119, firmware q3a35, sugar 0.84.15, Record.activity-66.
Recording a video (low quality) takes ~30sec to start recording. Records a video with no sound (mic light does not come up) and needs more than a minute to process a 10sec video that plays very poorly.
Audio-only recording and picture taking is OK.
Log is attached

Could you apply glive.py.patch and test vide recording mode once more.

Changed 10 years ago by alsroot

comment:4 in reply to: ↑ 3 ; follow-up: Changed 10 years ago by mavrothal

Replying to alsroot:

Could you apply glive.py.patch and test vide recording mode once more.

Unfortunatelly, no.
Again I get 1-2 sec in audio sound in both low and high quality.
The other thing I noticed is that in high quality the duration of the clip is half of the recorded. Like playing in 2x speed or a lot of drop frames and no timeline adjustment. Duration in low quality OK.
Care for logs?

comment:5 Changed 10 years ago by mavrothal

I mean "unfortunatelly , no improvement"

comment:6 in reply to: ↑ 4 Changed 10 years ago by alsroot

Replying to mavrothal:

Replying to alsroot:

Could you apply glive.py.patch and test vide recording mode once more.

Unfortunatelly, no.
Again I get 1-2 sec in audio sound in both low and high quality.
The other thing I noticed is that in high quality the duration of the clip is half of the recorded. Like playing in 2x speed or a lot of drop frames and no timeline adjustment. Duration in low quality OK.
Care for logs?

Nope, I think it is XO-1.5 particular issue (since the same Record on similar distro (Paraguay f11 based build) on XO-1 works fine), hw like Xv or so, I saw tickets on OLPC tracker. Unfortunately I don't have XO-1.5 and can't test.

comment:7 Changed 10 years ago by bernie

Reproduced on the XO-1 (os140py, sugar 0.84.15, Record 66).

The first time I recorded a video, everything went fine. The second time, the actity hung with the microphone and camera leds turned on.

The last line in the log says "record:glive.py: use fallback_bin"

comment:8 follow-up: Changed 10 years ago by bernie

Unfortunately, it looks like a kernel bug: the process is hung in uninterruptible sleep status (D).

comment:9 in reply to: ↑ 8 Changed 10 years ago by bernie

Replying to bernie:

Unfortunately, it looks like a kernel bug: the process is hung in uninterruptible sleep status (D).

I have not been able to reproduce this bug lately. Maybe it's simply vety hard to trigger?

comment:10 Changed 10 years ago by bernie

  • Cc dsd added

Daniel, is this ticket still relevant to Record?

If not, could you please close it?

comment:11 Changed 10 years ago by sascha_silbe

Can we close this one?

comment:12 Changed 9 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

Not reproducible in newest record. Please re-open if this issue is found again.

Note: See TracTickets for help on using tickets.