Opened 9 years ago

Closed 9 years ago

#1915 closed enhancement (fixed)

"Size mode" for Journal list view

Reported by: km0r3 Owned by: aa
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: journal Version: 0.84.x
Severity: Major Keywords: r+
Cc: bernie, aa, sascha_silbe, alsroot, erikos Distribution/OS:
Bug Status: Unconfirmed

Description

because the children want to know how big their files are.

Attachments (8)

sort_mode_icons.png (45.4 KB) - added by garycmartin 9 years ago.
screen shots of updated svg icons
view-created.svg (1.2 KB) - added by garycmartin 9 years ago.
Updated view-created icon (added a sort badge)
view-lastedit.svg (1.4 KB) - added by garycmartin 9 years ago.
Updated view-lastedit icon (added up/down sort badge)
view-size.svg (789 bytes) - added by garycmartin 9 years ago.
Updated view-size icon (added up/down sort badge and better line spacing)
0001-Size-mode-for-Journal-list-view-1915.patch (5.5 KB) - added by erikos 9 years ago.
Gary's icons for the journal-list filter
journal.png (17.5 KB) - added by erikos 9 years ago.
Correct labeling and using the right start icon
1915_journaltoolbox.patch (4.0 KB) - added by erikos 9 years ago.
Patch against jornaltoolbox
1915_all.patch (12.8 KB) - added by erikos 9 years ago.
Patch against all Journal (pylint checked and with rename of the toolbar icon)

Download all attachments as: .zip

Change History (41)

comment:1 Changed 9 years ago by sascha_silbe

  • Resolution set to invalid
  • Status changed from new to closed

Since 0.86 we show the size in the details view (#1033 / #1215).

comment:2 Changed 9 years ago by bernie

This isn't usable for the main usecase for which a user would care about the file size: finding large files which could be deleted to free up some space.

We also need to display the size of activities. Kids here have learned to open the terminal and type

cd Activities
du -sh *

Very cool, but it could be easier :-)

comment:3 Changed 9 years ago by aa

  • Cc aa added

comment:4 Changed 9 years ago by bernie

aa notes that we already have a proposed design for the size feature:

http://wiki.sugarlabs.org/go/Design_Team/Proposals/Journal#Extended_list_view_palette

I'd say: let's implement a useful subset of the UI that includes the object of this bug.

comment:5 Changed 9 years ago by aa

  • Cc sascha_silbe added

I will be working on this.

Sascha: should we reopen this bug, or track the larger issue of implementing the design proposal in a new one?

I will mail the list when I have an initial version of this feature.

comment:6 Changed 9 years ago by sascha_silbe

  • Distribution/OS Unspecified deleted
  • Resolution invalid deleted
  • Severity changed from Minor to Major
  • Status changed from closed to reopened
  • Summary changed from Show file size in Journal to "Size mode" for Journal list view

This one is fine. After all showing the file size in the details view isn't enough, so this ticket isn't really invalid.

comment:7 Changed 9 years ago by sascha_silbe

  • Owner changed from tomeu to aa
  • Status changed from reopened to assigned

Thanks for working on it. The design proposal is great; I never noticed it described where to show the size. Looking forward to seeing this implemented.

comment:8 Changed 9 years ago by aa

  • Keywords r? added
  • Status changed from assigned to accepted

Two patchsets were submitted yesterday to sugar-devel for review:
http://lists.sugarlabs.org/archive/sugar-devel/2010-May/023658.html for the DS work and http://lists.sugarlabs.org/archive/sugar-devel/2010-May/023664.html for the Journal side.

Should I attach the patches here as well? Or are the links enough?

I'm tagging the ticket as "r?", even if the review is now done in the mailing list.

comment:9 Changed 9 years ago by tomeu

  • Component changed from sugar to journal

comment:11 Changed 9 years ago by erikos

What is the status on this one? these are bigger changes, if we want to land it in 0.90 [1] we should start to land it soon (if applicable of course). aa can you update this ticket with the findings from the mailing list thread?

[1] http://wiki.sugarlabs.org/go/0.90/Roadmap#Schedule

comment:12 Changed 9 years ago by aa

  • Cc alsroot added

comment:13 follow-up: Changed 9 years ago by garycmartin

FWIW: I posted this to the Dextrose mail list back in July 30th, but got no response and seems to have drifted into the ether:

Hi Dextroseans, bug: Dextrose os300py on XO-1, Journal sorting option by creation date shows a bad dates for entries. My XO clock is correct, and have generated new entries from a number of different activities. All are listed as "41 years, 7months ago". FWIW even the order of the icons seems incorrect. Observation: Testing Turtle Blocks did it's usual (somewhat annoying) habit of automatically injecting a tamyblock.py into the Journal, this entry is showing the CORRECT creation date, Seconds ago, 3 minutes ago, etc; all other enries are wrong.

comment:14 follow-up: Changed 9 years ago by bernie

Confirmed on os400dx. Andres, could you give it a look? IMHO, we could get rid of the creation date altogether, it's not very useful.

Also, could you provide Spanish translations for the new strings?

comment:15 in reply to: ↑ 14 Changed 9 years ago by garycmartin

Replying to bernie:

IMHO, we could get rid of the creation date altogether, it's not very useful.

That would be a real shame, sorting by creation date allows a static view of past efforts so that entries you generated in close time proximity can be found together. This seems critical for reviewing past work in the Journal, "so what did you do at school last week?" or two weeks ago at a class outing. Also imagine the case where you write an essay and download some images from Browse to include, and perhaps use Calculate to calculate some results in your essay; sorting by creation date allows all these entries appear together.

comment:16 in reply to: ↑ 13 Changed 9 years ago by alsroot

  • Keywords r! added; r? removed

Replying to garycmartin:

FWIW: I posted this to the Dextrose mail list back in July 30th, but got no response and seems to have drifted into the ether:

Hi Dextroseans, bug: Dextrose os300py on XO-1, Journal sorting option by creation date shows a bad dates for entries. My XO clock is correct, and have generated new entries from a number of different activities. All are listed as "41 years, 7months ago". FWIW even the order of the icons seems incorrect. Observation: Testing Turtle Blocks did it's usual (somewhat annoying) habit of automatically injecting a tamyblock.py into the Journal, this entry is showing the CORRECT creation date, Seconds ago, 3 minutes ago, etc; all other enries are wrong.

Looks like ctime wasn't set (or 0),
aa: what about if sugar is failed to get ctime (or it is 0), use timestamp as ctime (listmodel.py)

comment:17 Changed 9 years ago by erikos

1282590783.607667 ERROR root: Error processing 'e603b6df-2b82-4917-8f86-c948fc4dc24f'
Traceback (most recent call last):
  File "/home/erikos/sugar-jhbuild-master/install/lib/python2.6/site-packages/carquinyol/datastore.py", line 125, in __update_index_cb
    self._index_store.store(uid, props)
  File "/home/erikos/sugar-jhbuild-master/install/lib/python2.6/site-packages/carquinyol/indexstore.py", line 261, in store
    term_generator.index_document(document, properties)
  File "/home/erikos/sugar-jhbuild-master/install/lib/python2.6/site-packages/carquinyol/indexstore.py", line 75, in index_document
    xapian.sortable_serialise(int(properties['filesize'])))
KeyError: 'filesize'
1282590783.608485 DEBUG root: Updating entry '4e73b31c-2d3f-4bfe-a73d-b3231dad4733' in index. 92 to go.

Changed 9 years ago by garycmartin

screen shots of updated svg icons

Changed 9 years ago by garycmartin

Updated view-created icon (added a sort badge)

Changed 9 years ago by garycmartin

Updated view-lastedit icon (added up/down sort badge)

Changed 9 years ago by garycmartin

Updated view-size icon (added up/down sort badge and better line spacing)

comment:18 Changed 9 years ago by garycmartin

Attached three updated Journal sort mode icons view-created, view-lastedit, and view-size. Main goal was to add iconography to represent sorting. Each icon is now badged with small up/down arrow triangles to the right of the main icon. Some small tidy ups, and view-size is clearer when shown as a small icon in menu drop down.

comment:19 Changed 9 years ago by garycmartin

FWIW, just added a separate ticket for a Journal renaming bug #2229 related to the new "View by size" sort mode.

comment:20 Changed 9 years ago by aa

Repos with the latest patches can be found here:

http://git.sugarlabs.org/projects/sugar/repos/aa
http://git.sugarlabs.org/projects/sugar-datastore/repos/aa

New in this version:

  • Added new property 'creation_time' instead of using the old ctime.
  • More care taken to catch possible exceptions while indexing and in the Journal UI.

comment:21 Changed 9 years ago by aa

  • Cc erikos added

comment:22 follow-up: Changed 9 years ago by erikos

Andres, I applied your patches here. Had to remove my DS, since it was not recoverable after the last testing. I was able to reproduce #2229. Maybe you can have a look into that. (The log activity shows size=Empty, too btw).

The toolbar icon shows the list when starting first, shouldn't that be whatever filter is currently applied (size, created, last edit)?

Changed 9 years ago by erikos

Gary's icons for the journal-list filter

comment:23 follow-up: Changed 9 years ago by erikos

While testing I found that enhancement might be a good addition to that Feature: #2232

Gary, I wonder if the filter-palette should not be revealed directly when left-clicking on it to match the behavior with the other filters... (/me hopes he does not open a can of works with that comment)

comment:24 in reply to: ↑ 22 Changed 9 years ago by garycmartin

Replying to erikos:

The toolbar icon shows the list when starting first, shouldn't that be whatever filter is currently applied (size, created, last edit)?

Sorry if I was not clear, yes the toolbar icon should be showing the icon for the currently applied sort, so by default that would be view-lastedit.

comment:25 in reply to: ↑ 23 Changed 9 years ago by garycmartin

Replying to erikos:

Gary, I wonder if the filter-palette should not be revealed directly when left-clicking on it to match the behavior with the other filters... (/me hopes he does not open a can of works with that comment)

+1 my understanding was that it was agreed that ideally all buttons that have no direct left click action, should immediately open their full palette on left (and right) click. Clicking UI components on screen should instantly provide some visual feedback, either through their direct action (resuming an activity, taking a photo, right aligning some text, inserting an image etc), or through immediately displaying their palette with the available choices. The other obvious example where we currently have this wrong is the large central XO icon on the home view, should should not have to hover or right click to get the palette to appear, a single left click should show it as well.

comment:26 Changed 9 years ago by alsroot

Replying to aa:

http://git.sugarlabs.org/projects/sugar-datastore/repos/aa

datastore.py:update_index_cb()

  • better to include time.strptim() to try block since ctime wasn't implemented in sugar and we can't rely on activities that used it on theirs own

datastore.py:create()

  • initiate creation_time by timestamp not by time.time()

datastore.py:update()

  • initiate creation_time by timestamp not by time.time()

Changed 9 years ago by erikos

Correct labeling and using the right start icon

comment:27 Changed 9 years ago by erikos

The screenshot attached contains the correct labeling of the filter options and the right icon when starting the Journal (Gary).

Changed 9 years ago by erikos

Patch against jornaltoolbox

comment:28 Changed 9 years ago by erikos

The patch above addresses the comments from Gary. I moved from a radiotoolbutton to a normal toolbutton and did a few pylint cleanups.

Changed 9 years ago by erikos

Patch against all Journal (pylint checked and with rename of the toolbar icon)

comment:31 Changed 9 years ago by aa

Merged in Sugar mainline for great justice.

comment:32 Changed 9 years ago by erikos

  • Keywords r+ added; r! removed

Sugar artwork pushed as:

http://git.sugarlabs.org/projects/sugar-artwork/repos/mainline/commits/55a2fe370eb22ac042ac1c4670f8fa3a111c8f38

Andres, please reference the commit and then you can close this ticket.

I assigned you #2229 as the first related bug :)

Thanks everyone!

Note: See TracTickets for help on using tickets.