Opened 11 years ago

Closed 10 years ago

#1912 closed defect (obsolete)

Write - 60 does not render Arabic correctly

Reported by: reuben Owned by: sayamindu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Critical Keywords:
Cc: cjl Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

When typing words letters do not connect correctly. You can type the same word three times and it gets rendered differently each time. Rendering is better when using Abiword in Gnome on a 1.5.

This issue and #1770 lead me to believe we need to update to a newer rev of Abiword source and then fix the issue in #1770.

Sayamindu, what is a timeline for this to happen? A group will be deploying a custom image to 2500 XOs in the next couple of weeks. Can we get this into that image in that timeframe?

Change History (5)

comment:1 Changed 11 years ago by sayamindu

Is this F-11 based build (XO-1.5) or XO-1 ?

comment:2 Changed 11 years ago by reuben

The rendering issue is seen on an XO 1.0 build 8.2.1

comment:3 Changed 11 years ago by sayamindu

  • Status changed from new to accepted

I'm trying to figure out how easy it is to backport/build the latest Abiword in F-9. Could you possibly provide the keystrokes that I need to use to reproduce this ? It would be incredibly helpful for my testing.

comment:4 Changed 11 years ago by cjl

  • Cc cjl added

Is this a duplicate of:

Write activity doesn't do Arabic shaping
http://dev.laptop.org/ticket/2229 where khaled has provided screenshots?

comment:5 Changed 10 years ago by RafaelOrtiz

  • Resolution set to obsolete
  • Status changed from accepted to closed

Please test with newer versions of write.

Note: See TracTickets for help on using tickets.