Opened 11 years ago

Closed 10 years ago

#1904 closed defect (fixed)

OLPC-Measure Activity –Activity get stuck after recording

Reported by: Ruwan F'do Owned by: walter
Priority: High Milestone: Unspecified
Component: Measure Version: 0.84.x
Severity: Major Keywords:
Cc: lmacken@… Distribution/OS: OLPC
Bug Status: New

Description

Description

After recording according to the time period which user given it gets stuck and cannot continue from that point.

Step to recreate the defect

  1. Power on OLPC
  2. Wait for the activity ring/ activity Icons (Desktop).
  3. Open the measure activity
  4. Go to the sound tab
  5. Select 30second on drop down list
  6. Click the record button

Actual Result

After 30 seconds activity got stuck and couldn’t do anything within the activity.

Expected Result

After 30 seconds it should save recorded file and redirect to sound tab.

Tested Environment

OS Build: OS 116
Machine Type: XO 1.5
Firmware: Q3A35
Security Disable: Yes
Sugar Version: 0.84.14
Activity Version: 29

Attachments (1)

0001-Call-gtk.threads_-enter-leave-before-after-taking-th.patch (1.1 KB) - added by lmacken 10 years ago.
A patch that seems to resolve this issue

Download all attachments as: .zip

Change History (11)

comment:1 Changed 11 years ago by walter

  • Priority changed from Unspecified by Maintainer to High

comment:2 Changed 11 years ago by Ruwan F'do

Note:- Same error has occurred in OS119.

comment:3 Changed 10 years ago by walter

Update: We'll be refactoring this code... hopefully we'll find the problem. A log file would be helpful.

comment:4 Changed 10 years ago by saketc

I encountered the same error with Measure locking up after a recording. It occurred at a random interval of time though, from 30 seconds - several minutes after hitting record. I have the latest version of the code, 4979c15fb2fc54b8e36704beff2cb12c77b71ffe, and I posted a copy of the log file created below.

1276709277.170549 WARNING root: .has_key() is deprecated, use 'in'
1276709277.266954 DEBUG Measure: controls: ['Master', 'Capture']
1276709277.267916 DEBUG Measure: Getting master (Master) volume: 28 (18470)
1276709277.268044 WARNING Measure: No Mic control, returning constant volume
1276709277.338367 WARNING root: No gtk.AccelGroup in the top level window.
1276709277.342451 WARNING root: No gtk.AccelGroup in the top level window.
1276709277.988903 DEBUG Measure: ====================================
1276709277.990295 DEBUG Measure: Set Sensor Type to 1
1276709277.990449 WARNING Measure: No Mic Bias control, not setting mute
1276709278.056261 DEBUG Measure: Set volume of Capture (Capture) to 40 (26214)
1276709278.056585 WARNING Measure: No Mic Boost control, not setting mute
1276709278.056691 DEBUG Measure: ====================================
/usr/lib/python2.6/site-packages/sugar/graphics/window.py:290: DeprecationWarning: use toolbar_box instead of toolbox
  warnings.warn('use toolbar_box instead of toolbox', DeprecationWarning)
** (sugar-activity:2664): DEBUG: Got client ID "10b85a7ba217cfea99127670927829731000000025380003"
** (sugar-activity:2664): DEBUG: Setting initial properties
** (sugar-activity:2664): DEBUG: Received SaveYourself(SmSaveLocal, !Shutdown, SmInteractStyleNone, !Fast) in state idle
** (sugar-activity:2664): DEBUG: Sending SaveYourselfDone(True) for initial SaveYourself
** (sugar-activity:2664): DEBUG: Received SaveComplete message in state save-yourself-done

comment:5 Changed 10 years ago by walter

Not much info in the log, unfortunately. I'll take a closer look after I finish the refactoring.

comment:6 Changed 10 years ago by lmacken

I was able to reproduce this issue on my XO 1.5 with the latest Measure code from git.

For me it locking up on this line:

    x_orig, y_orig = window.get_origin()

http://git.sugarlabs.org/projects/measure/repos/mainline/blobs/master/journal.py#line339

Changed 10 years ago by lmacken

A patch that seems to resolve this issue

comment:7 Changed 10 years ago by lmacken

  • Cc lmacken@… added

comment:8 Changed 10 years ago by lmacken

Walter committed this patch in f2ac4e4583339bcfa1d7894ee6b8b8d2e10f79a3

Right now the patch wraps gtk.threads_{enter,leave} around the entire JournalInteraction.save_screenshot method. We may want to optimize it and only wrap it around the gtk calls.

comment:9 Changed 10 years ago by walter

I think we are OK now (v30). Please reopen if the problem persists.

comment:10 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.