Opened 11 years ago

Closed 10 years ago

#1866 closed defect (notsugar)

OLPC-Screen Rotation Functionality – Screen rotation button is not working as expected in XO1.5

Reported by: qazigzag Owned by: tomeu
Priority: Normal Milestone: Unspecified
Component: Sugar Version: 0.84.x
Severity: Minor Keywords: OS115
Cc: Distribution/OS: OLPC
Bug Status: New

Description

Description:
When clicking on the rotate screen button it is not working XO 1.5 OLPC

Step to recreate the defect:

  1. Power on OLPC
  2. Wait for the activity ring (Desktop).
  3. Press the rotate screen button.
  4. Verify the OLPC screen rotating.

Actual Result:
Screen did not rotate, when press the rotate screen button.

Expected Result:

When user clicks on the rotate screen button, screen should rotate.

Tested Environment
OS: Sugar and GNOME (Dual boot)
Machine Type: XO 1.5
Build: OS 115
Firmware: Q3A35

Change History (4)

comment:1 Changed 11 years ago by qazigzag

  • Summary changed from OLPC-Screen Rotation Functionality – Unexpected error function as follows “screen should not rotate the using rotate Screen Button” to OLPC-Screen Rotation Functionality – Unexpected error function as follows “screen should rotate the using rotate Screen Button”

comment:2 Changed 11 years ago by Kathy

  • Summary changed from OLPC-Screen Rotation Functionality – Unexpected error function as follows “screen should rotate the using rotate Screen Button” to OLPC-Screen Rotation Functionality – Screen rotation working button is not as expected in XO1.5

comment:3 Changed 10 years ago by Kathy

  • Summary changed from OLPC-Screen Rotation Functionality – Screen rotation working button is not as expected in XO1.5 to OLPC-Screen Rotation Functionality – Screen rotation button is not working as expected in XO1.5

comment:4 Changed 10 years ago by quozl

  • Distribution/OS changed from Other (name your distribution in the description) to OLPC
  • Resolution set to notsugar
  • Status changed from new to closed

Closing this, because it is not a fault with Sugar or activities.

The place this is being tracked is laptop.org #9530 (xrandr screen rotation support) and the root cause is lack of support for rotation in the graphics driver for XO-1.5 platform.

Note: See TracTickets for help on using tickets.