Opened 11 years ago

Closed 11 years ago

#1859 closed defect (fixed)

float save/restore rounding to int

Reported by: walter Owned by: walter
Priority: High Milestone: Unspecified
Component: Turtleart Version: Git as of bugdate
Severity: Critical Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Tony Forster has reported this problem:

First save
0, ["number", "0.1"], 374, 248, [null, null?, [-1, ["turtle", 1], 0, 0, 0, 0, 50, 5]]

Second save
0, ["number", 0.10000000000000001], 374, 248, [null, null?, [-1, ["turtle", 1], 0, 0, 0, 0, 50, 5]]

Third save
0, ["number", 0], 374, 248, [null, null?, [-1, ["turtle", 1], 0, 0, 0, 0, 50, 5]]

But I cannot reproduce it.

Change History (5)

comment:1 Changed 11 years ago by walter

  • Priority changed from Unspecified by Maintainer to High

comment:2 Changed 11 years ago by tonyforster

Originally found on Sugar. Can replicate with V84 on Gnome on XO1 hardware

comment:3 Changed 11 years ago by walter

Please check to see if v85 or v86 still has this problem.

comment:4 Changed 11 years ago by tonyforster

Fixed in V86, Presumably V85 too

comment:5 Changed 11 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.