Opened 11 years ago

Closed 9 years ago

#1850 closed defect (notabug)

Make the default web-browsing activity in SoaS a well-maintained upstream

Reported by: mchua, lucian, erikos Owned by: mchua sdz
Priority: High Milestone: Unspecified
Component: Sugar on a Stick (SoaS) Version: Unspecified
Severity: Critical Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

A web-browsing Activity is a feature requirement for SoaS because it is the mechanism via which users install new Activities from http://activities.sugarlabs.org. Historically, we have used the Browse Activity. However, Browse is orphaned upstream.

The slightest change in xulrunner (in Fedora) gives us pain. but since xulrunner is pretty strongly maintained by the folks at Red Hat, there is not much we can do. But if anybody develops and maintains a new activity for browsing the net, we should look at that too.

We need to either find a maintainer or to look for something better for the next release.

Change History (3)

comment:1 Changed 11 years ago by walter

  • Reporter changed from mchua to mchua, lucian, erikos

Since when is Browse not maintained? Admittedly, there are a lot of open tickets... Lucian may be a candidate for taking it on.

comment:2 Changed 11 years ago by sdz

http://www.mail-archive.com/sugar-devel@lists.sugarlabs.org/msg12133.html

I hear Lucian might be able to do something soon here, though. We need to make sure this is sustainable, though.

comment:3 Changed 9 years ago by pbrobinson

  • Resolution set to notabug
  • Status changed from new to closed

This is a problem agreed. Its not a problem of SoaS. The main problem is Browse isn't well maintained by SugarLabs. As such this isn't a SoaS bug.

Note: See TracTickets for help on using tickets.