Opened 11 years ago

Closed 10 years ago

Last modified 7 years ago

#1823 closed defect (fixed)

README refers to obsolete info

Reported by: timclicks Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Trivial Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

sugar/README refers to http://wiki.laptop.org/go/Sugar_with_sugar-jhbuild

Updated to:

For details see: http://wiki.sugarlabs.org/go/Development_Team/Jhbuild

Sugar-jhbuild will automatically download the latest of Sugar's
dependencies as well as Sugar itself directly from their source 
repositories, rather than relying on source packages that may have 
become stale. These are generic instructions on how to use jhbuild 
to get up and running with Sugar.

  $ cd sugar-jhbuild
  $ ./sugar-jhbuild update
  $ ./sugar-jhbuild depscheck
  $ ./sugar-jhbuild build

Attachments (1)

0001-Updated-README-intro.patch (1.2 KB) - added by timclicks 11 years ago.

Download all attachments as: .zip

Change History (8)

Changed 11 years ago by timclicks

comment:1 follow-up: Changed 11 years ago by sascha_silbe

  • Keywords r? added
  • Milestone changed from Unspecified by Release Team to 0.88
  • Severity changed from Unspecified to Trivial
  • Status changed from new to assigned
  • Version changed from Unspecified to Git as of bugdate

This is a dupe of #1541, but since you attached a patch I'm leaving this bug open and closing #1541 instead.

I don't think we should explain how to use sugar-jhbuild in the source package (especially since it will get outdated again), but rather add information
a) for distro packagers (dependencies, how to build, ...) and
b) for users (how to start, where to find documentation / get help, ...).

comment:2 in reply to: ↑ 1 Changed 11 years ago by timclicks

Replying to sascha_silbe:

This is a dupe of #1541, but since you attached a patch I'm leaving this bug open and closing #1541 instead.

I don't think we should explain how to use sugar-jhbuild in the source package (especially since it will get outdated again), but rather add information
a) for distro packagers (dependencies, how to build, ...) and
b) for users (how to start, where to find documentation / get help, ...).

Please review http://pastebin.be/23922 as interim fix.

comment:3 Changed 11 years ago by erikos

Hi Tim,

what you pasted can not be shown. Can you attach it again?

comment:4 Changed 11 years ago by erikos

  • Milestone changed from 0.88 to 0.88.x

comment:5 Changed 11 years ago by erikos

  • Milestone changed from 0.88.x to 0.88

Actually, it does not touch any code, so it can go into 0.88

comment:6 Changed 10 years ago by tomeu

  • Keywords r+ added; r? removed
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:7 Changed 7 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.