Opened 9 years ago

Closed 9 years ago

Last modified 6 years ago

#1814 closed enhancement (fixed)

Use only one entry point for activity launch

Reported by: alsroot Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

For now, code that launch/resume activities is scattered. Having only one entry point makes launching related code more robust.

Attachments (2)

sugar-1814.patch (11.5 KB) - added by alsroot 9 years ago.
0001-Do-not-allow-empty-string-activity_id-1814.patch (913 bytes) - added by alsroot 9 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 follow-up: Changed 9 years ago by alsroot

  • Keywords r? added

Patch contains also #1719 fix because it heavily depends of this ticket fix.

Changed 9 years ago by alsroot

comment:2 in reply to: ↑ 1 Changed 9 years ago by alsroot

Replying to alsroot:

Patch contains also #1719 fix because it heavily depends of this ticket fix.

looks like #1719 fix could be less invasive, so this ticket patch does not contain #1719 fix

comment:3 Changed 9 years ago by tomeu

  • Keywords r+ added; r? removed

This patch is great, please push if you have already tested each code path that has been made to use misc.launch().

comment:4 Changed 9 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 9 years ago by alsroot

  • Keywords r? added; r+ removed
  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:6 follow-up: Changed 9 years ago by alsroot

Regression that was introduced by implementation patch.

comment:7 in reply to: ↑ 6 Changed 9 years ago by alsroot

Replying to alsroot:

Regression that was introduced by implementation patch.

At least in one case activity_id could be , from misc.resume().

comment:8 Changed 9 years ago by tomeu

  • Keywords r+ added; r? removed

r+, but change the patch to test for both is None and empty string.

comment:9 follow-up: Changed 9 years ago by alsroot

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:10 in reply to: ↑ 9 Changed 9 years ago by alsroot

Replying to alsroot:

http://git.sugarlabs.org/projects/sugar/repos/mainline/commits/2c429471b3c4384ec2f3fe23513f6964e8f39a72

|TestCase|

  • resume image from usb in Imageviewer activity
  • there are two new buttons in activities tray

comment:11 Changed 6 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.