Opened 10 years ago

Closed 10 years ago

Last modified 6 years ago

#1813 closed defect (fixed)

Do not remove internal metadata fields while rewriting object

Reported by: alsroot Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Unspecified
Severity: Major Keywords: r? olpc-0.84
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by alsroot)

For now, on every IndexStore.store() call, entirely directory is being swept out including internally used fields like checksum.

|TestCase|

  • upload .xoj to journal
  • upload the same .xoj once more
  • only one(first one) valid entry in Journal

Attachments (1)

0001-Do-not-remove-internal-metadata-fields-while-rewriti.patch (1008 bytes) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (7)

comment:1 Changed 10 years ago by alsroot

  • Description modified (diff)

comment:2 Changed 10 years ago by alsroot

One of consequences of this bug is that on updating object's file, it is impossible to remove previous checksum entry since object's checksum field was swept out.

comment:3 Changed 10 years ago by alsroot

  • Keywords r? olpc-0.84 added

comment:4 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

comment:5 Changed 6 years ago by dnarvaez

  • Component changed from sugar-datastore to Sugar

comment:6 Changed 6 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.