Opened 9 years ago

Closed 9 years ago

Last modified 9 years ago

#1790 closed defect (fixed)

TurtleArt-83.tar.bz2: Filesize does not match recorded size

Reported by: sf Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: gentoo-overlay Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Gentoo
Bug Status: Unconfirmed

Description

emerge -1 turtleart-activity
Calculating dependencies ... done!

Verifying ebuild manifests

Emerging (1 of 1) sugar-activities/turtleart-activity-83 from sugar
Downloading 'http://download.sugarlabs.org/sources/sucrose/fructose/TurtleArt/TurtleArt-83.tar.bz2'

--2010-03-05 19:52:13-- http://download.sugarlabs.org/sources/sucrose/fructose/TurtleArt/TurtleArt-83.tar.bz2
Resolving download.sugarlabs.org (download.sugarlabs.org)... 140.186.70.53, 2002:8cba:4635::1
Connecting to download.sugarlabs.org (download.sugarlabs.org)|140.186.70.53|:80... connected.
HTTP request sent, awaiting response... 302 Found
Location: http://ftp.snt.utwente.nl/pub/software/sugarlabs/sources/sucrose/fructose/TurtleArt/TurtleArt-83.tar.bz2 [following]
--2010-03-05 19:52:14-- http://ftp.snt.utwente.nl/pub/software/sugarlabs/sources/sucrose/fructose/TurtleArt/TurtleArt-83.tar.bz2
Resolving ftp.snt.utwente.nl (ftp.snt.utwente.nl)... 130.89.149.20, 2001:610:1908:a000::149:20
Connecting to ftp.snt.utwente.nl (ftp.snt.utwente.nl)|130.89.149.20|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 1038984 (1015K) [application/octet-stream]
Saving to: “/usr/lib/portage/distfiles/TurtleArt-83.tar.bz2”

100%[===============================================================>] 1,038,984 481K/s in 2.1s

2010-03-05 19:52:16 (481 KB/s) - “/usr/lib/portage/distfiles/TurtleArt-83.tar.bz2” saved [1038984/1038984]

('Filesize does not match recorded size', 1038984L, 3723930)
!!! Fetched file: TurtleArt-83.tar.bz2 VERIFY FAIL ED!
!!! Reason: Filesize does not match recorded size
!!! Got: 1038984
!!! Expected: 3723930

Change History (3)

comment:1 follow-up: Changed 9 years ago by walter

I don't know what the root cause of this problem is... I just pushed a new copy to d.sl.o. Could you please report back if the problem persists?

comment:2 Changed 9 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

I've regenerated Manifest file and pushed it to overlay.

comment:3 in reply to: ↑ 1 Changed 9 years ago by alsroot

Replying to walter:

I don't know what the root cause of this problem is... I just pushed a new copy to d.sl.o. Could you please report back if the problem persists?

If you pushed not the same file with the same name it will affect all distro packages, since they keep file size and checksum of tarball, so in that case new name is required. But maybe it was just my fault (wrong download on my side).

Note: See TracTickets for help on using tickets.