Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#1785 closed defect (incomplete)

SoaS v2 Blueberry doesn't save anything, revisited

Reported by: David Kergyl Owned by: tomeu
Priority: Normal Milestone:
Component: Sugar on a Stick (SoaS) Version: 0.86.x
Severity: Blocker Keywords: USB save Journal boot
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

To begin with, let me say I love this product! But . . .

My Sugar on a Stick v2 Blueberry USB SoaS, created yesterday (3 March 2010), doesn't save anything from a previous session (after a normal shutdown and reboot). The reboot seems normal, with no errors. Both Activity changes (new downloads and erasures) and Journal entries from the previous session are gone.

I meticulously followed the USB SoaS creation instructions for Windows, including creating the maximum-size overlay (3.9 GB, as I recall).

I am using a 4GB PNY Optima Attache USB stick. I tried the stick on two machines. The first is a Dell Latitude D630 with 2x2.0GHz dual-core Intel CPU and 2GB RAM (booted from USB). The second is a legacy IBM Thinkpad 2675 Transnote (booted from helper CD). Neither saved any data to the stick.

On the IBM, I can see the USB drive (named FEDORA) on the menu, but it is reported to have 0MB Free. On the Dell, I don't even see the USB drive on the menu.

On the IBM, boot.log says "Unable to find persistent overlay; using temporary."

I plan to try flashing the drive again with a smaller overlay.

Change History (7)

comment:1 follow-up: Changed 11 years ago by David Kergyl

  • Keywords Journal boot added

I flashed the same stick again with a smaller (1GB) overlay. I was happy to see that this time Journal worked on the Dell, which boots directly from the USB stick. But on the older IBM nothing at all was being written to the Journal as I worked.

Does booting from the helper CD on the IBM prevent saving the Journal to the stick? If so, the instructions should be revised to warn users about this problem.

Is there a maximum overlay size? Does the stick require any free space of its own?

I'll try building the SoaS stick again, on an identical stick, with a maximum overlay, to replicate the problem.

comment:2 Changed 11 years ago by David Kergyl

Correction to original post: The first overlay was 3.222Gb.

comment:3 Changed 11 years ago by David Kergyl

I created another, identical Live USB with the maximum overlay (3.2Gb). This time Journal works and saves fine (but Sugar reports it to be only about 400Mb in size).

Considering that I can't replicate the problem, and the original log files are gone, I think this ticket can be closed.

comment:4 Changed 11 years ago by sascha_silbe

  • Resolution set to incomplete
  • Status changed from new to closed

Closing on request of reporter.

comment:5 in reply to: ↑ 1 Changed 11 years ago by David Kergyl

Replying to David Kergyl:

... But on the older IBM nothing at all was being written to the Journal as I worked.

I discovered that the issue with the IBM was that the BIOS date was set incorrectly. New entries _were_ being written to the Journal, but because the Journal is sorted in time/date order, the new entries were not appearing at the top of the list, where I was looking.

comment:6 Changed 11 years ago by sascha_silbe

  • Component changed from sugar to SoaS
  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

comment:7 Changed 7 years ago by dnarvaez

  • Milestone Blueberry deleted

Milestone Blueberry deleted

Note: See TracTickets for help on using tickets.