Opened 9 years ago

Closed 9 years ago

#1779 closed defect (fixed)

Speak dies in robot mode

Reported by: quozl Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Speak Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

On XO-1 os802b1 Speak-12 downloaded from activities.sugarlabs.org, activated from journal, worked fine until Robot mode was entered, then the key sequence "alice?" was typed, followed by enter, and the activity terminated immediately.

vu.lux.olpc.Speak-3.log was being tailed at the time; the only output at the point of failure was:

WARNING: maximum recursion depth exceeded (input='CATCHALL')

The symptom was reproducible.

Attachments (1)

vu.lux.olpc.Speak-4.log (3.6 KB) - added by quozl 9 years ago.
log of failing instance

Download all attachments as: .zip

Change History (6)

Changed 9 years ago by quozl

log of failing instance

comment:1 Changed 9 years ago by alsroot

  • Owner changed from jminor to alsroot
  • Status changed from new to assigned

comment:2 Changed 9 years ago by alsroot

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in v13

comment:3 Changed 9 years ago by quozl

  • Resolution fixed deleted
  • Status changed from closed to reopened

Related problem reported in https://answers.launchpad.net/soas/+question/103677

Speak-13 activity stops if the robot is given ">?" as input.

Tail of log shows only the following at point of failure:

WARNING: No match found for input: >

comment:4 Changed 9 years ago by quozl

Running Speak in Terminal shows more details as to the cause of the symptom:

% cd Activities/Speak.activity
% sugar-launch vu.lux.olpc.Speak
...
WARNING: No match found for input: >
Floating point exception

comment:5 Changed 9 years ago by alsroot

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.