Opened 11 years ago

Closed 10 years ago

#1776 closed defect (fixed)

Imageviewer should be able to open SVGs

Reported by: walter Owned by: sayamindu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Imageviewer Version: Unspecified
Severity: Critical Keywords:
Cc: erikos, walter, alsroot Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

By adding image/svg-xml to the mime-types list in activity/activity.info, you should be able to open SVG files in Imageviewer.

Please see related ticket 1772 re a discussion about doing the same for Browse.

Perhaps Imageviewer should be the default activity: mime.defaults in /usr/share/sugar/data (sugar/data/mime.defaults). But certainly Paint, which changes the format from SVG to PNG should not be the default. And you definitely want to be able to open SVGs in Browse, if only to be able to take advantage of View Source.

I am marking this as Critical since user data is lost under the current conditions where Paint is the only option.

Change History (2)

comment:1 Changed 10 years ago by alsroot

  • Cc alsroot added

comment:2 Changed 10 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.