Opened 11 years ago

Closed 11 years ago

#1762 closed defect (duplicate)

OperationalError: database is locked

Reported by: RemyD Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

How to Reproduce

While doing a POST operation on /ticket/1761, Trac issued an internal error.

(please provide additional details here)

Request parameters:

{'__FORM_TOKEN': u'343f8aea9a2a13cb6c559e02',
 'action': u'leave',
 'cnum': u'2',
 'comment': u"Replying to [comment:1 sascha_silbe]:\r\n> There is already a Video Chat component with gdesmott as owner. I guess this is a different project, so what should the component be named? Open Video Chat? That might be confusing to users...\r\n> \r\n\r\nSascha,\r\n\r\nI was following orders from mel chua :) This project will be continuing development on the existing code base, so if we can be added to the existing components, that would work just fine I'd reckon. Lemme know what the next steps are.\r\n--RemyD.",
 'field_cc': u'',
 'field_component': u'git.sugarlabs.org',
 'field_distribution': u'Unspecified',
 'field_keywords': u'sugar@RIT, videochat',
 'field_milestone': u'Unspecified by Release Team',
 'field_priority': u'Unspecified by Maintainer',
 'field_severity': u'Blocker',
 'field_status_field': u'Needinfo',
 'field_summary': u'Component Request - Git and Trac for Open Video Chat Team @ RIT',
 'field_type': u'task',
 'field_version': u'Unspecified',
 'id': u'1761',
 'replyto': u'1',
 'submit': u'Submit changes',
 'ts': u'2010-02-27 00:23:06+00:00'}

User Agent was: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1.8) Gecko/20100216 Fedora/3.5.8-1.fc11 Firefox/3.5.8

System Information

Trac 0.11.6
Python 2.5.2 (r252:60911, Jan 21 2010, 04:10:42)
[GCC 4.2.4 (Ubuntu 4.2.4-1ubuntu3)]
setuptools 0.6c8
SQLite 3.4.2
pysqlite 2.3.2
Genshi 0.5.1
CustomFieldAdmin 0.2.2
jQuery: 1.2.6

Python Traceback

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 450, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/web/main.py", line 206, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/ticket/web_ui.py", line 182, in process_request
    return self._process_ticket_request(req)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/ticket/web_ui.py", line 504, in _process_ticket_request
    valid = self._validate_ticket(req, ticket) and not problems
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/ticket/web_ui.py", line 977, in _validate_ticket
    for field, message in manipulator.validate_ticket(req, ticket):
  File "build/bdist.linux-sparc64/egg/tracspamfilter/adapters.py", line 67, in validate_ticket
    FilterSystem(self.env).test(req, author, changes)
  File "build/bdist.linux-sparc64/egg/tracspamfilter/api.py", line 133, in test
    score, ['%s (%d): %s' % r for r in reasons]).insert()
  File "build/bdist.linux-sparc64/egg/tracspamfilter/model.py", line 138, in insert
    '\n'.join(self.reasons)))
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/util.py", line 64, in execute
    return self.cursor.execute(sql_escape_percent(sql), args)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/sqlite_backend.py", line 80, in execute
    PyFormatCursor.execute(self, *args)
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/sqlite_backend.py", line 59, in execute
    args or [])
  File "/usr/lib/python2.5/site-packages/Trac-0.11.6-py2.5.egg/trac/db/sqlite_backend.py", line 51, in _rollback_on_error
    return function(self, *args, **kwargs)
OperationalError: database is locked


Change History (1)

comment:1 Changed 11 years ago by sascha_silbe

  • Resolution set to duplicate
  • Status changed from new to closed

Dupe of #698.

Note: See TracTickets for help on using tickets.