Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#1758 closed defect (notabug)

Write no longer works on 0.82

Reported by: quozl Owned by:
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Write Version: Unspecified
Severity: Unspecified Keywords:
Cc: garycmartin Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Write-67 does not work on Sugar 0.82 ("Import Error: No module named widgets") and it is not clear if a version for Sugar 0.82 is available. Write-60 works. Reported by New Zealand test team, Alastair Munro.

Change History (4)

comment:1 Changed 10 years ago by garycmartin

  • Resolution set to notabug
  • Status changed from new to closed

Hi, thanks for the ticket, Write-67's compatibility is correctly listed as Sugar: 0.86 – 0.86 on ASLO. Users downloading/updating from ASLO with Sugar (via software update or the Browse activity) are given the latest compatible version automatically. Taking a quick look at http://activities.sugarlabs.org/en-US/sugar/addons/versions/4201 Write-63 is Sugar 0.84 only, and Write-60 is indeed the latest compatible version for Sugar 0.82 users.

I have on my todo list to back-port the old toolbar support into a new version of Write, this may improve the situation, but I'm not sure what the Write-63 0.84 compatibility break was all about (I'll retest in 0.82 incase it's something easy to fix, however it's worth noting that there have been many bug fixes and enhancements to the underlying abiwrite libraries that 0.82 users would be missing out on).

comment:2 Changed 10 years ago by quozl

  • Cc garycmartin added

Thanks.

A root cause appears to be that the tester used another system to download the bundle rather than the laptop they were testing.

People assume that a web page will show the same fundamental data independently of how they view it. I've tested that web page some more, and Browse on Sugar 0.82 shows Write-60, and Browse on Sugar 0.84 shows Write-63.

Is there a way to obtain the latest compatible version independently of Software Update or Browse? This would reduce reports of bugs, and make it easier to share specific recommendations by e-mail and IRC.

comment:3 follow-up: Changed 10 years ago by garycmartin

For now, I'd recommend when you download from ASLO, make sure to check the "Works with Sugar..." and that it matches the version of Sugar that needs to be tested. You can download older versions by scrolling down the page a little and selecting "View Older Versions" in the release note section, this will list all previous versions and what version of Sugar they are known to be compatible with.

comment:4 in reply to: ↑ 3 Changed 10 years ago by alsroot

Replying to garycmartin:

For now, I'd recommend when you download from ASLO, make sure to check the "Works with Sugar..." and that it matches the version of Sugar that needs to be tested. You can download older versions by scrolling down the page a little and selecting "View Older Versions" in the release note section, this will list all previous versions and what version of Sugar they are known to be compatible with.

Advanced search was fixed, so while choosing particular sugar version in search list, ASLO should provide proper .xo tarball to download.

Note: See TracTickets for help on using tickets.