Opened 11 years ago

Closed 11 years ago

#1752 closed defect (invalid)

./setup fix_manifest is generating locale files and adding them to MANIFEST

Reported by: garycmartin Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Sugar 0.87.3. When using ./setup fix_manifest, it is now triggering the generation of locale files (in what is likely your clean source working directory) and adding them into the MANIFEST file. This is a change in behaviour that increases the bundle file sizes with data that is being generated anyway at install time from the .po files.

Change History (4)

comment:1 follow-up: Changed 11 years ago by walter

Is this new behavior? I thought that it was always this way.

comment:2 in reply to: ↑ 1 Changed 11 years ago by garycmartin

Replying to walter:

Is this new behavior? I thought that it was always this way.

Well, maybe it happened a while back and I just didn't notice. I don't have old builds at hand to test (I'm working away from home). I'm just going to edit the MANIFEST by hand and make sure I don't include the locale directory in git or bundles, but pity the newbe.

comment:3 follow-up: Changed 11 years ago by walter

The MANIFEST file will not impact your git repository. The only way that the locale files would be added is if you do a git add. However, these files are included in the .xo bundle and .tar file. Not sure if they are necessary...

comment:4 in reply to: ↑ 3 Changed 11 years ago by garycmartin

  • Resolution set to invalid
  • Status changed from new to closed

Replying to walter:

However, these files are included in the .xo bundle and .tar file. Not sure if they are necessary...

I must be going senile in my old age, just did some tests and locale files are not re-generated at install time so looks like they have to be shipped/duplicated in the bundle. Will have to go and release Physics-4 again... :-(

Note: See TracTickets for help on using tickets.