Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#1747 closed enhancement (obsolete)

Default sugar-emulator window size does not follow HIG

Reported by: alsroot Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords: r!
Cc: sascha_silbe, Eben Distribution/OS: Unspecified
Bug Status: New

Description (last modified by alsroot)

It uses 800x600 hardcoded size instead of 16x12 cells

Attachments (1)

0001-Minor-sugar-emulator-tweaks-1747.patch (2.8 KB) - added by alsroot 9 years ago.
Actualize patch to 0.90

Download all attachments as: .zip

Change History (9)

comment:1 Changed 9 years ago by alsroot

  • Description modified (diff)
  • Summary changed from Minor sugar-emulator tweaks to Default sugar-emulator window size does not follow HIG

comment:2 follow-up: Changed 9 years ago by sascha_silbe

  • Cc sascha_silbe added
  • Keywords r? added
  • Version changed from Unspecified to Git as of bugdate

I'm not convinced changing sugar-emulator to use some odd size (832x624 with the default scaling of 72 if I've got my math right) is a good idea. Sugar should scale well to real-world screen sizes. 800x600 was chosen because it's used in actual, current hardware. If we really want to raise the bar, we should go for 1024x600 (used by several netbooks, e.g. Asus Eee PC).

comment:3 in reply to: ↑ 2 Changed 9 years ago by alsroot

Replying to sascha_silbe:

I'm not convinced changing sugar-emulator to use some odd size (832x624

with the default scaling of 72

it is default scaling, see bin/sugar.in

if I've got my math right) is a good idea. Sugar should scale well to real-world screen sizes. 800x600 was chosen because it's used in actual, current hardware. If we really want to raise the bar, we should go for 1024x600 (used by several netbooks, e.g. Asus Eee PC).

but we already have HIG which says 16x12 cells and it is sugar emulator thus having not fully emulated (by default, since user can pass proper parameters) sugar could be wrong way

comment:4 Changed 9 years ago by tomeu

  • Cc Eben added

Betting that Eben has thought something about it.

comment:5 Changed 9 years ago by erikos

  • Bug Status changed from Unconfirmed to New
  • Milestone changed from Unspecified by Release Team to 0.90

I am not sure Eben does read tickets on a regular basis anymore...

Assigned the 0.90 milestone, as it is not needed for 0.88, imho.

comment:6 Changed 9 years ago by tomeu

  • Keywords r! added; r? removed

Changed 9 years ago by alsroot

Actualize patch to 0.90

comment:7 Changed 6 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed

comment:8 Changed 6 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.