Opened 9 years ago

Closed 8 years ago

#1722 closed defect (fixed)

Calculate - UI string error

Reported by: cjl Owned by: rwh
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Calculate Version: Unspecified
Severity: Unspecified Keywords:
Cc: garycmartin, RafaelOrtiz, godiard Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

eqnparserhelp.py:107

"sinh(x), return the hyperbolic tangent of x. Given by sinh(x) / cosh(x)"

should read

"tanh(x), return the hyperbolic tangent of x. Given by sinh(x) / cosh(x)"

Change History (8)

comment:1 Changed 9 years ago by cjl

  • Cc garycmartin added

comment:2 Changed 9 years ago by rwh

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in git a while ago

comment:3 Changed 8 years ago by cjl

  • Resolution fixed deleted
  • Status changed from closed to reopened

Unfortunately the fix did not make it into the PO file.

http://git.sugarlabs.org/calculate/mainline/blobs/master/po/Calculate.pot

comment:4 Changed 8 years ago by garycmartin

Sorry, being dense here, do you need me to correct the source (looks like it given a very quick scan though line numbers have changed), or is this something else going on?

comment:5 Changed 8 years ago by cjl

  • Cc RafaelOrtiz added

The POT file in git is not updated, therefore not updating in Pootle properly. Weshould discuss with RafaelOrtiz correct procedure.

comment:6 Changed 8 years ago by garycmartin

FWIW: Looking in the current source of Calculates functions.py I see

436 def tanh(x):
437     return math.tanh(x)
438 tanh.__doc__ = _(
439 'tanh(x), return the hyperbolic tangent of x. Given by sinh(x) / cosh(x)')

That looks identical to the text fix in the ticket. I've not tried to run ./setup.py getpot and commit the updated Calculate.pot as I was under the assumption (please do correct me) that the pootle scripts do that step (and pushing a new pot file manually from my end would cause manual steps to accept the changes at the pootle end).

comment:7 Changed 8 years ago by cjl

  • Cc godiard added

adding Gonzalo Odiard as cc. Gonzalo can you take a look at this?

comment:8 Changed 8 years ago by cjl

  • Resolution set to fixed
  • Status changed from reopened to closed

fixed and pulled to Pootle

Note: See TracTickets for help on using tickets.