Opened 11 years ago

Closed 11 years ago

#1718 closed defect (wontfix)

Cannot see who submitted suggestions

Reported by: anderson861 Owned by: sayamindu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: localization Version: Unspecified
Severity: Unspecified Keywords: pootle, suggestion,
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

While checking suggestions that have been submitted, I can no longer see who submitted the suggestion. This is probably due to the new Pootle install that we are using. I do have full permissions on the project(namely eToys in the Mongolian project, probably in others too), and can accept suggestions, but it doesn't show who it is from.

Change History (3)

comment:1 Changed 11 years ago by cjl

Also filed with Pootle upstream

http://bugs.locamotion.org/show_bug.cgi?id=1358

comment:2 Changed 11 years ago by cjl

I have done some further investigation and it looks like many of the suggestions on the lang-mn etoys project are from a user:versionmerge. This is not a registered Pootle user on our server, so I have a theory that these are suggestions that pre-existed the migration from Pootle 1.2 to Pootle 2.0 (Sugar Labs / OLPC server was migrated recently). It is possible that the migration process lost some information about who made the suggestions, and the suggestor name has been substituted with user:versionmerge during the migration process.

I'm not sure of this, but it is my current working theory. I can see that on other projects, suggestions made since the migration do properly show the suggesting users identity.

comment:3 Changed 11 years ago by cjl

  • Resolution set to wontfix
  • Status changed from new to closed

The above explanation seems to be more-or-less correct. There doesn't seem to be anything to be done about it on the Sugar Labs / OLPC side of things. It has been confirmed that new suggestions display username as expected, so this is only an issue with pre-migration suggestions and will not be an issue with new, post-migration suggestions.

Resolving this as wontfix.

Note: See TracTickets for help on using tickets.