Opened 11 years ago

Closed 8 years ago

#1682 closed defect (notsugar)

tuxmath-1.xo invokes SDL_Pango - that package is not included in F11-based builds

Reported by: RafaelOrtiz Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

Recently released Tuxmath Activity runs correctly on build 802B1. But it
does not launch on build os11, nor on build 200 -- neither of those builds
provide needed file libSDL_Pango.so.1

taken from http://dev.laptop.org/ticket/9994

Change History (5)

comment:1 follow-up: Changed 11 years ago by quozl

Is SDL_Pango a declared dependency for the Sugar platform? If so, then the builds are faulty for not including the package. If not, then Tuxmath Activity is depending on a package that is provided only in old OLPC builds.

comment:2 in reply to: ↑ 1 Changed 11 years ago by tomeu

Replying to quozl:

Is SDL_Pango a declared dependency for the Sugar platform? If so, then the builds are faulty for not including the package. If not, then Tuxmath Activity is depending on a package that is provided only in old OLPC builds.

IMO, unless it's not well packaged in distros, stuff on which activities depended on OLPC builds should be made part of the Sugar Platform http://wiki.sugarlabs.org/go/0.86/Platform_Components

comment:3 Changed 11 years ago by quozl

SDL_Pango is well packaged in distros, and TuxMath activity does depend on it. Downstream has solved immediate problem by inclusion of SDL_Pango in build.

comment:4 Changed 8 years ago by cjl

dirakx since http://dev.laptop.org/ticket/9994 is closed, can this also be closed?

comment:5 Changed 8 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from new to closed

Not a sugar bug.

Note: See TracTickets for help on using tickets.