Opened 9 years ago

Closed 6 years ago

Last modified 6 years ago

#1660 closed defect (obsolete)

Home list view activities date sorting should be reversed (new at top, old at bottom)

Reported by: garycmartin Owned by: tomeu
Priority: Unspecified by Maintainer Milestone:
Component: Sugar Version: Git as of bugdate
Severity: Minor Keywords:
Cc: humitos, sascha_silbe Distribution/OS: Unspecified
Bug Status: New

Description

In the Home list view, activities are currently date sorted with the oldest at top, and newest at bottom. This order should be reversed so that list view uses the same order metaphor as the Journal with newest objects at the top, and oldest objects at the bottom.

Attachments (3)

HomeList.png (73.4 KB) - added by mikus 8 years ago.
logs.CSN750001F8.2010-10-10.22-25-10.tar.bz2 (380.5 KB) - added by mikus 8 years ago.
FYI - system dump of F14_on_XO-1 system, just after booting (but with Home List View "oldest first")
HomelistNew.png (75.7 KB) - added by RafaelOrtiz 7 years ago.

Download all attachments as: .zip

Change History (16)

comment:1 Changed 9 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New

Currently the activities list is "unsorted" by default. The fact that it's sorted chronologically is a leakage of bundle registry internals (_scan_directory(): "Sort by mtime to ensure a stable activity order").
The best place to implement the sorting is ActivitiesTreeView (using model.set_sort_column_id(...)), but GTK highlights the current sort column and I haven't found a way to prevent that yet.

comment:2 follow-up: Changed 9 years ago by mikus

For os295py (sugar 0.88.1), the following patch solved the problem:

  From: Jorge Saldivar <jsaldivar@paraguayeduca.org>
  ---
   src/jarabe/desktop/activitieslist.py |    2 +-
   1 files changed, 1 insertions(+), 1 deletions(-)

  diff --git a/src/jarabe/desktop/activitieslist.py b/src/jarabe/desktop/activitieslist.py
  index 87f2af0..546ac6f 100644
  --- a/src/jarabe/desktop/activitieslist.py
  +++ b/src/jarabe/desktop/activitieslist.py
  @@ -228,7 +228,7 @@ class ListModel(gtk.TreeModelSort):
                       '<span style="italic" weight="light">%s</span>' % \
                               (activity_info.get_name(), tags)
 
  -        self._model.append([activity_info.get_bundle_id(),
  +        self._model.prepend([activity_info.get_bundle_id(),
                               favorite,
                               activity_info.get_icon(),
                               title,
  -- 

comment:3 in reply to: ↑ 2 Changed 9 years ago by sascha_silbe

Replying to mikus:

For os295py (sugar 0.88.1), the following patch solved the problem:

  --- a/src/jarabe/desktop/activitieslist.py
  +++ b/src/jarabe/desktop/activitieslist.py
  @@ -228,7 +228,7 @@ class ListModel(gtk.TreeModelSort):
                       '<span style="italic" weight="light">%s</span>' % \
                               (activity_info.get_name(), tags)
 
  -        self._model.append([activity_info.get_bundle_id(),
  +        self._model.prepend([activity_info.get_bundle_id(),

This is a workaround, not a fix. I'm ambivalent about whether we should apply it. It doesn't look like anyone is going to come up with a proper fix soon, so this workaround would be useful to users. OTOH once it looks OK to the user, I doubt anyone will ever fix it properly.

comment:4 Changed 8 years ago by mikus

Reproduced on 0.90 XO-1 (F14) sugar 0.90.2

I have over 100 Activities installed on my systems -- that amounts to many many screens worth of Home List View. It is quite bothersome to have to scroll to the bottom of Home List View, every time I reboot, in order to reach the entries for the newest Activities (which usually are the ones I've just installed, and therefore want to test).

[Note: On occasion, on 0.90 I've even seen that the Home List View order happened to be reversed, with the newest Activities at the beginning -- but that situation has not been reproducible.]

Changed 8 years ago by mikus

Changed 8 years ago by mikus

FYI - system dump of F14_on_XO-1 system, just after booting (but with Home List View "oldest first")

comment:5 follow-ups: Changed 7 years ago by humitos

  • Cc humitos added

Could you write down the steps to test this?

I applied the patch that you mentioned here but it still function in the same way (no order at all)

comment:6 in reply to: ↑ 5 Changed 7 years ago by RafaelOrtiz

Replying to humitos:

Could you write down the steps to test this?

I applied the patch that you mentioned here but it still function in the same way (no order at all)

Did you make install after doing the change?

comment:7 Changed 7 years ago by humitos

Yes, that's why I asked, because I didn't see any difference. So, maybe I'm not testing the right thing. I mean, I think that it should work in some way but maybe I'm wrong.

Could you write step by step how it should work? Where I should click and what I should expect?

Thanks,

Changed 7 years ago by RafaelOrtiz

comment:8 Changed 7 years ago by RafaelOrtiz

Process is as follows.
*First go to home view and check that ordering is from old to new as seen in HomeList.png

  • apply the patch.
  • Make install.
  • Check that new ordering is like HomeListNew.png, from new to old, thus fixing the ticket.

comment:9 in reply to: ↑ 5 Changed 7 years ago by sascha_silbe

  • Cc sascha_silbe added

Replying to humitos:

Could you write down the steps to test this?

I applied the patch that you mentioned here but it still function in the same way (no order at all)

Did you check the Activities List View? The Activities Favourites View shouldn't be affected.

My comment still applies, BTW.

comment:10 follow-up: Changed 7 years ago by RafaelOrtiz

Sasha, following your comment, I think that there is no harm in applying this one, although it's workaround.

comment:11 in reply to: ↑ 10 Changed 7 years ago by RafaelOrtiz

Sascha, following your comment, I think that there is no harm in applying this one, although it's workaround.

comment:12 Changed 6 years ago by godiard

  • Resolution set to obsolete
  • Status changed from new to closed

The activities list now use a alphabetic order. This change is not longer useful.

Closing as obsolete.

comment:13 Changed 6 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.