Opened 11 years ago

Closed 10 years ago

Last modified 9 years ago

#1658 closed defect (fixed)

Using _p for marking translateable strings messes up xgettext

Reported by: sayamindu Owned by: garycmartin
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Clock Version: Unspecified
Severity: Unspecified Keywords:
Cc: cjl Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

In sugar-toolkit, the xgettext invocation (which generates the POT files) is hardcoded to look for _ as translateable marker, and hence all strings with _p get ignored.

Is there any specific reason you are using _p ? If there is any reason, we can try to figure out how to make sugar-toolkit understand _p, and if not, it would be best to revert to _ instead of _p

Change History (3)

comment:1 Changed 10 years ago by RafaelOrtiz

  • Cc cjl added

As for translations on

http://git.sugarlabs.org/clock/mainline/blobs/master/po/es.po

It seems that both sugar-toolkit and pootle are o.k with pgettext.


comment:2 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

Fixing as per the comment above, re-open if the use of _p (pgettext) crashes in some way xgettext.

comment:3 Changed 9 years ago by garycmartin

FWIW I've just switched Clock over to _ instead of _p, seems to be testing fine.

Note: See TracTickets for help on using tickets.