Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#1657 closed enhancement (wontfix)

Turtle Art has some .png images

Reported by: RafaelOrtiz Owned by: walter
Priority: Normal Milestone:
Component: Turtleart Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

looking inside /images there still are some png images that can be transform to .svg like :

flowmask.png
myblocksmask.png
numbersmask.png
penmask.png
sensorsmask.png
templatesmask.png
turtlemask.png

Change History (3)

comment:1 Changed 11 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

These mask files need to be stored as PNG since the SVG files get rendered with anti-aliasing which messes with the mask values in unexpected ways. If you know of a way to turn off antialiasing in the SVG-to-PIXBUF conversion, I could make these files into SVG. I plan to use a different mechanism altogether for selecting block prototypes in the refactoring of Turtle Art that is currently under way.

comment:2 Changed 11 years ago by RafaelOrtiz

Ok good to know, i encountered some problems wuth the .pngs while packaging turtleart for debian/ubuntu, not as an activity but as a normal app.

i had to change the .png to .svg would be nice to know how are you planning to make the process better.

thanks.

comment:3 Changed 8 years ago by dnarvaez

  • Milestone 0.88 deleted

Milestone 0.88 deleted

Note: See TracTickets for help on using tickets.