Opened 11 years ago

Closed 10 years ago

Last modified 7 years ago

#1648 closed defect (fixed)

Measure-29 on XO 1.5

Reported by: tabitha Owned by: walter
Priority: Normal Milestone:
Component: Measure Version: 0.84.x
Severity: Unspecified Keywords:
Cc: Distribution/OS: OLPC
Bug Status: Assigned

Description

Sound slider when moved past approx 90% on the range of the oscilloscope goes erratic. Math bug in display? It goes vertical and spikey and off screen all of a sudden.
Still works when you take the slider back.
Sugar build 54 on XO 1.5. Firmware Q3A18.

Change History (7)

comment:1 Changed 11 years ago by walter

  • Milestone changed from 0.84 to 0.90
  • Priority changed from Unspecified by Maintainer to Normal

comment:2 Changed 11 years ago by walter

  • Bug Status changed from Unconfirmed to Assigned

comment:3 Changed 11 years ago by walter

If you use alsamixer from the Terminal activity and then turn off mic boost then it seems to work as expected.

I'll investigate setting the proper parameters on launch.

comment:4 Changed 10 years ago by GenJamGuy

The problem is due to the way the slider is mapped to capture_gain in the cb_page_sizey() method of toolbar_side.py. Instead of mapping the continuous slider position to the capture_gain with a formula, it is mapped discretely to one of 5 fixed levels in an if/else block. The discontinuity at the "approx 90%" point is caused by that point being a threshold between a gain of 100 and a gain of 300.

From a user interface perspective, one could change the slider to lock on one of 5 positions and keep the discrete mapping to capture_gain. A better solution would be to map the continuous slider position to a continuous capture_gain, provided the hardware supports more than 5 sensitivity levels.

comment:5 Changed 10 years ago by walter

I've removed the crazy math from the slider in the version in git. (The code had been hardwired for the XO 1.0 hardware that had only 4 levels.) Hope to have this sorted out when I release v30. See Ticket #1070

comment:6 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed in v30.

comment:7 Changed 7 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.