Opened 10 years ago

Closed 3 years ago

Last modified 3 years ago

#1646 closed enhancement (fixed)

No way to force-close (kill) an activity

Reported by: sascha_silbe Owned by: tomeu
Priority: Normal Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Resolved

Description

If an activity has gotten into a state where it doesn't close itself anymore, there's no way for the user to do a clean shutdown (the only option left is forcibly powering off the machine).
Several other UIs are offering to forcibly close an application if it doesn't voluntarily close after a certain amount of time. Another option is offerring the option to kill the application in the regular menu (like e.g. ion3 does), but IMO the first option is better since it's harder to accidently shoot yourself in the foot.

Change History (7)

comment:1 Changed 10 years ago by sascha_silbe

Oh, just to be clear: While the issue of "no clean shutdown possible" can be solved by simply ignoring activities that refuse to close during shutdown IMO it should not be _necessary_ to do a shutdown just to kill a renegade activity.

comment:2 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:3 Changed 6 years ago by dnarvaez

  • Type changed from defect to enhancement

comment:4 Changed 6 years ago by dnarvaez

  • Bug Status changed from Unconfirmed to New
  • Priority changed from Unspecified by Maintainer to Normal

comment:6 Changed 3 years ago by Himanshu786

  • Bug Status changed from New to Resolved
  • Resolution set to fixed
  • Status changed from new to closed

Now you can forcibly close the app by just Simcity and here is the link https://github.com/sugarlabs/sugarcity-activity

comment:7 Changed 3 years ago by Himanshu786

Now you can forcibly close the app by just Simcity and here is the link https://github.com/sugarlabs/sugarcity-activity .So my e-mail ID is himanshuwindows8.1@…

Note: See TracTickets for help on using tickets.