Opened 11 years ago

Closed 11 years ago

#1641 closed enhancement (notabug)

Speak fails on launch without net connection

Reported by: cjb Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Browse Version: Unspecified
Severity: Unspecified Keywords:
Cc: dsd, mikus, alsroot, mstone, quozl Distribution/OS: Unspecified
Bug Status: New

Description

According to this OLPC bug, Speak is crashing on launch with no net connection:

http://dev.laptop.org/ticket/9945

It seems obvious to me that Speak should never depend on a net connection. What's going on?

Change History (6)

comment:1 Changed 11 years ago by mstone

  • Cc alsroot mstone added

comment:2 Changed 11 years ago by quozl

  • Cc quozl added

comment:3 Changed 11 years ago by alsroot

Speak was switched to services(http://wiki.sugarlabs.org/go/Activity_Team/Services) to install missed gst-espeak plugin which is missed on XO.

This issue with disabled connection after downloading but before first launch was predicted but can be fixed only from shell side(see offline mode in http://wiki.sugarlabs.org/go/Features/Zero_Install_integration). I guess in most cases it should work as is(since user downloaded activity from ASLO), other cases(like deploying previously downloaded from ASLO activities) could be treaded in separate way e.g. ASLO or something which deploy "offline" ASLO activities can automatically bundle all 0install dependencies.

comment:4 Changed 11 years ago by alsroot

  • Bug Status changed from Unconfirmed to New
  • Component changed from Speak to activities.sugarlabs.org
  • Distribution/OS changed from OLPC to Unspecified
  • Owner changed from jminor to alsroot
  • Status changed from new to assigned
  • Type changed from defect to enhancement

It already could be done somehow on ASLO, since we have user's arch from useragent string and language from ASLO's language selector and I'm working on it. In the rest cases like complicated deps that require not only arch to resolve the full deps tree or in cases when users already have activity dependencies http://wiki.sugarlabs.org/go/Features/Zero_Install_integration could pass "online" mode flag in Browse's useragent string

comment:5 Changed 11 years ago by alsroot

  • Component changed from activities.sugarlabs.org to Browse

hmm.. it will break mirroring workflow since downloaded .xo could be different for the same activity. I guess better tweak Browse to split .xo downloading to two phases - binary less .xo and 0install deps.

I'm going to implement such fix for 0.82+ Browses.

comment:6 Changed 11 years ago by alsroot

  • Resolution set to notabug
  • Status changed from assigned to closed

I've reverted CB-9 and Speak-12 to previous versions and closing this ticket since the whole Sugar Services will be accessible from development environment(somehow).

Note: See TracTickets for help on using tickets.