Opened 11 years ago

Closed 11 years ago

#1640 closed defect (fixed)

Speak PO file messed up

Reported by: cjl Owned by: sayamindu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: localization Version: Unspecified
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

There was a problem with speak.po, I downloaded and made some changes, but the attempt to upload does not seem to have gone well.

Attachments (1)

speak.po (6.6 KB) - added by cjl 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by cjl

comment:1 Changed 11 years ago by cjl

  • Resolution set to notabug
  • Status changed from new to closed

I figured out that I just had to use the update command to clear this up. It's all better now.

comment:2 Changed 11 years ago by cjl

  • Resolution notabug deleted
  • Status changed from closed to reopened

Nope, The PO file is messed up. I think it is a Unicode versus UTF format thing, but I only have a locked-down Windows box and not my usual Ubuntu box to work on this. Sayamindu, I'm sorry to have to ask you to help me clean up a mess that I made.

comment:3 Changed 11 years ago by cjl

This is specifically the Spanish language speak.po

http://translate.sugarlabs.org/es/honey/

comment:4 Changed 11 years ago by sayamindu

It seems to be fine to me. Normally encoding errors occur if the charset value is set to something odd. With the current file, it is set to ASCII, which is, while not recommended, should not cause problems with what is currently there.
To be safe, PO files should be UTF-8 encoded.

comment:5 Changed 11 years ago by sayamindu

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.