Opened 11 years ago

Closed 11 years ago

Last modified 8 years ago

#1626 closed defect (incomplete)

Boot Helper needs selinux=0

Reported by: jdsimmons Owned by: sdz
Priority: Normal Milestone:
Component: Sugar on a Stick (SoaS) Version: SoaS 2 (Blueberry)
Severity: Critical Keywords: helper CD boot
Cc: walter.bender@… Distribution/OS: Fedora
Bug Status: Assigned

Description

I have tried to boot SoaS Blueberry on a number of older machines that I own using a boot CD. In every single case the boot artwork shows every dot but the last one or two (probably two) and then hangs. When I press Escape to see what the problem is I see the following messages:

/sbin/dmsquash-live-root: 166: grep: not found
dracut Warning: Machine in enforcing mode and cannot execute load_policy
dracut Warning: To disable selinux, add selinux=0 to the kernel command line.
dracut Warning: not continuing

and there it hangs, forever.

I've tried this on two different older computers that cannot boot directly from USB. I have also tried booting the USB on my XO, the only machine I own that can do that, and it seems to work. I would guess it's an issue with the boot CD?

Change History (6)

comment:1 Changed 11 years ago by sascha_silbe

  • Distribution/OS changed from SoaS to Unspecified

Bulk change distribution=SoaS -> component=SoaS

comment:2 Changed 11 years ago by sdz

  • Bug Status changed from Unconfirmed to New
  • Distribution/OS changed from Unspecified to Fedora
  • Version changed from Unspecified to 0.86.x

You might need to do this - please let me know if it works! :)

Press the <Escape> key at the blue screen, which appears for a second before the normal boot process starts. You'll be presented a short menu, at which you can directly press tab, then just add the selinux=0 argument in the appearing line, and then boot by pressing the <Enter> key.

It's a known issue that occurred in earlier snapshots. I haven't seen it in the final build, yet, but well.

comment:3 Changed 11 years ago by overbyte

  • Cc walter.bender@… added
  • Keywords helper CD boot added

I get the same error when booting SOAS Blueberry using the helper CD. I followed the suggestion to interrupt the bootloading and append the "selinux=0" option to the command line, then pressed Enter. It bootloaded fine then. Can't someone get this option added to the command cooked into the helper CD?

comment:4 Changed 11 years ago by sdz

  • Bug Status changed from New to Assigned
  • Priority changed from Unspecified by Maintainer to Normal
  • Summary changed from dracut Warning: Machine in enforcing mode and cannot execute load_policy to Boot Helper needs selinux=0
  • Version changed from 0.86.x to SoaS 2 (Blueberry)

I think I did a recompose of the boot helper a couple of weeks ago. Is it fixed now?

comment:5 Changed 11 years ago by sdz

  • Resolution set to incomplete
  • Status changed from new to closed

Please reopen if this problem still persists.

comment:6 Changed 8 years ago by dnarvaez

  • Milestone Blueberry deleted

Milestone Blueberry deleted

Note: See TracTickets for help on using tickets.