Opened 11 years ago

Closed 10 years ago

#1611 closed task (fixed)

Translation hookup needed for several activities

Reported by: bemasc Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: localization Version: Unspecified
Severity: Unspecified Keywords:
Cc: cjl Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Watch Me: http://git.sugarlabs.org/projects/watch-me/repos/mainline
ShareTerm: http://git.sugarlabs.org/projects/shareterm/repos/mainline
StopWatch: http://dev.laptop.org/git/activities/stopwatch/

All these activities could use translations.

In general, I've become confused as to how translations are working. For example, I don't see Distance/acoustic-measure listed in pootle anywhere.

Change History (6)

comment:1 in reply to: ↑ description Changed 11 years ago by garycmartin

Replying to bemasc:

In general, I've become confused as to how translations are working. For example, I don't see Distance/acoustic-measure listed in pootle anywhere.

Hi, FWIW at least distance is in: http://translate.sugarlabs.org/en/honey/acoustic-measure-activity.po?translate=1&view=1

comment:2 Changed 11 years ago by cjl

  • Cc cjl added

It is certainly fair to say that the documentation on the localization process needs improvement. In particular, for the developer audience, we could use a recipe for the steps needed to get the activity they maintain set up for localization.

Initial set-up steps that bemasc (or any activity maintainer) should take.

1) bemasc should generate the POT file and place it in a "po" directory in the git repo.

See Paint(Oficina) Source Tree as an example of a Honey activity set up for L10n. Notice the po directory and the contents thereof, one of which is a .pot file

http://git.sugarlabs.org/projects/paint/repos/mainline/trees/master

2) bemasc should add user pootle as a committer on the activity's project in git. pootle is the username for the pootle server through which individual language admins can commit their specific language PO files in Pootle and cause the pootle server to commit translations (the language specific .po files into the po directory) in git.

There are additional steps needed for these activities to appear in the Honey project on the Pootle server (black magic that Sayamindu performs to make the Pootle-repo push work), but these two steps by the activity maintainer need to happen first.

comment:3 Changed 11 years ago by cjl

For Stopwatch (still hosted at dev.laptop.org) it seems the po directory (and POT file) have been created, but off-hand it doesn't look like pootle has commit privs yet. And of course the black magic needs to happen.

http://dev.laptop.org/git/activities/stopwatch/tree/

You can see an example of the Pootle server committing changes to the Italian PO file to the Record Activity.
http://dev.laptop.org/git/activities/record/commit/

comment:4 Changed 11 years ago by sayamindu

Pootle does not have write privileges on any of the repositories. For those hosted on git.sugarlabs.org, just add the user pootle to the user list associated with the repository.
For the repository hosted on dev.laptop.org, it is a bit more complicated. You will need to poke someone with admin on that machine to allow the pootle user to write to that repository.

comment:5 Changed 10 years ago by cjl

  • Owner changed from sayamindu to RafaelOrtiz
  • Status changed from new to assigned

comment:6 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from assigned to closed

1 watch-me doesn't have a .POT generated (setup.py genpot) (lacks 118n)
2 Niether shareterm.(lacks 118n)
3 http://translate.sugarlabs.org/es/honey/stopwatch.po stopwatch now in pootle more langs must be added by admins.

  1. Separated bugs could be filled for watch-me and shareterm but it would be an overkill due to the fact that these are not maintainded anymore.


Note: See TracTickets for help on using tickets.