Opened 10 years ago

Closed 5 years ago

#1608 closed defect (fixed)

no wireless disconnect functionality

Reported by: dsd Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Major Keywords: r!
Cc: sascha_silbe Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description (last modified by sascha_silbe)

Originally reported at http://dev.laptop.org/ticket/9788

The menu items for disconnecting from a wireless network are just stubs. It would be useful to have a real, working disconnect option.

Attachments (1)

1608.patch (6.5 KB) - added by sascha_silbe 10 years ago.
fix network disconnect and discard buttons (quozl)

Download all attachments as: .zip

Change History (11)

comment:1 Changed 10 years ago by sascha_silbe

  • Bug Status changed from Unconfirmed to New
  • Cc sascha_silbe added
  • Description modified (diff)
  • Severity changed from Unspecified to Major
  • Version changed from Unspecified to Git as of bugdate

No wonder I was having trouble with that, and I always thought its NetworkManagers fault...
Setting severity to Major as it causes considerable confusion.

comment:2 Changed 10 years ago by sascha_silbe

  • Milestone changed from Unspecified by Release Team to 0.88

Changed 10 years ago by sascha_silbe

fix network disconnect and discard buttons (quozl)

comment:3 Changed 10 years ago by sascha_silbe

  • Keywords r? added

I've rebased the patch provided by quozl (thanks!) in OLPC#9788 on top of current git master and tested it on XO-1. Works fine so far, but I don't quite grok what jarabe.model.network.NMSettingsConnection.set_connected() is supposed to do, so please review that part extra carefully.

comment:4 Changed 9 years ago by quozl

jarabe.model.network.NMSettingsConnection.set_connected() sets the autoconnect value, which is fetched by NetworkManager, so that next time Sugar starts, NetworkManager will not require user interaction in order to begin connecting to a network.

comment:5 Changed 9 years ago by tomeu

  • Keywords r! added; r? removed

Looks like James has a patch that supersedes this, so I'm taking it out the review queue assuming this one doesn't need a review any more.

comment:6 Changed 9 years ago by bernie

Quozl, where is this patch?

comment:7 Changed 9 years ago by erikos

  • Milestone changed from 0.88 to 0.90

This only landed in 0.84 as part of this patch:

http://git.sugarlabs.org/projects/sugar/repos/mainline/commits/fcb1cec3fedfda3115f2ca72adeef53d81d500aa

We should get this into 0.90, too.

comment:8 Changed 6 years ago by dnarvaez

  • Milestone changed from 0.90 to Unspecified

comment:9 Changed 6 years ago by dnarvaez

  • Bug Status changed from New to Unconfirmed

comment:10 Changed 5 years ago by godiard

  • Resolution set to fixed
  • Status changed from new to closed

This was implemented years ago.

Note: See TracTickets for help on using tickets.