Opened 11 years ago

Closed 9 years ago

#1596 closed defect (fixed)

drag-and-drop file causes screen flicker

Reported by: dsd Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: journal Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Using sugar-jhbuild on Fedora, also reproduced on Sugar-0.84: dragging and dropping a file from a USB disk onto the Journal icon on the bottom left will cause a screen flash, while the progress bar is displayed and the whole view is refreshed.

There is no need for a refresh in this case. I think it is happening because the datastore is sending a signal that there is a new file in the Journal, and the Journal is not considering the fact it's not displaying the datastore contents before refreshing the screen.

Change History (1)

comment:1 Changed 9 years ago by dsd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in http://dev.laptop.org/ticket/10841 (commit 782f013040527abea5a641254003ec0c70b42216)

Note: See TracTickets for help on using tickets.