Opened 11 years ago

Closed 8 years ago

#1589 closed defect (fixed)

Clock 5 does not speak in F11- XO1/os9 Sugar 0.84.7

Reported by: mavrothal Owned by: garycmartin
Priority: Normal Milestone: Unspecified
Component: Clock Version: Unspecified
Severity: Unspecified Keywords:
Cc: sridhar, RafaelOrtiz Distribution/OS: OLPC
Bug Status: Needinfo

Description

In XO-1 running F11-XO1/os9 with Sugar 0.84.7 the clock 5 activity runs OK but does not speak the time.
Sound and speech in other apps is OK.
Nothing special in the Log

Attachments (1)

Clock.log (813 bytes) - added by mavrothal 11 years ago.

Download all attachments as: .zip

Change History (11)

Changed 11 years ago by mavrothal

comment:1 Changed 11 years ago by garycmartin

  • Status changed from new to accepted

Thanks for the report, have an email from Yioryos Asprobounitis as well about this. Speech/sound is not an area of expertise for me but I will try to take a look and see if I can reproduce this fail case and see if something is missing from the distro or if some other API could be used instead.

comment:2 Changed 9 years ago by garycmartin

  • Bug Status changed from Unconfirmed to Needinfo
  • Priority changed from Unspecified by Maintainer to Normal

Hi, could you retest with the new Clock-6 release? I can confirm the talking clock works well on the 802 olpc build, and works on the latest os19, os20, os21 test builds, though there are some espeak/audio related hangs/crashes in these new builds (see http://dev.laptop.org/ticket/10948). Another step to try is to use the Terminal activity and type:

espeak "hello world"

and see if it works there (this is roughly what clock does in the background).

comment:3 follow-up: Changed 9 years ago by mavrothal

Tried clock 6 in the XO-1 with F11 OLPC os860/sugar 0.84 with (Speak v18 or v25).
No speaking and nothing suspicious in the log or dmesg
`espeak "my word"' in terminal also fails. Just hangs there w/o any error in console or dmesg.
So looks like an espeak issue

*Howevwer* after a failed clock speak, if you close and reopen the activity then there is NO clock, but text time/date is OK.
More important the XO-1 will fail even to shutdown, unless you restart (ctrl-alt-del) X, (there is nothing relevant in Xorg.log).
This does not appear to be an espeak issue because if you first issue espeak in terminal and quit it (ctrl+C) the clock activity starts and shows the clock fine and the XO shuts down ok too.

On the XO-1 running F14 OLPC os22/Sugar0.92 clock 6 speaks the time once (occasionally half a second time) and then no more.
espeak works fine from terminal before you run the Clock activity but not after.
Again on Clock re-launch after a failed speaking session, there is no clock and the XO-1 fails to restart/shutdown till you force-restart X.
This is probably a different bug, but is also speaking clock related...

comment:4 in reply to: ↑ 3 ; follow-up: Changed 9 years ago by garycmartin

Thanks for re-testing.

Replying to mavrothal:

*Howevwer* after a failed clock speak, if you close and reopen the activity then there is NO clock, but text time/date is OK.
More important the XO-1 will fail even to shutdown, unless you restart (ctrl-alt-del) X, (there is nothing relevant in Xorg.log).
This does not appear to be an espeak issue because if you first issue espeak in terminal and quit it (ctrl+C) the clock activity starts and shows the clock fine and the XO shuts down ok too.

If you run top in Terminal after the clock fails to speak you will see the hung espeak process ticking away, this is what is causing the subsequent issue. If you killall espeak, and then resume Clock activity the face will correctly draw.

On the XO-1 running F14 OLPC os22/Sugar0.92 clock 6 speaks the time once (occasionally half a second time) and then no more.
espeak works fine from terminal before you run the Clock activity but not after.

I find espeak run from the terminal will lock up just the same after a hand full of trys, either part way through speach, or at the end of speech, just like from Clock.

Again on Clock re-launch after a failed speaking session, there is no clock and the XO-1 fails to restart/shutdown till you force-restart X.
This is probably a different bug, but is also speaking clock related...

Try killall espeak from Terminal to see if this helps, I've not seen the XO-1 fail to restart/shutdown here.

FWIW, the espeak issue appears to be that it is not correctly working with the audio subsystem. The other activities using speech seem to have avoided this case as they all need access to the sound data so they can draw animated mouths, or highlight words one by one in sync; to do this they all seem to be using espeak just to generate a wav file that they either save to /tmp or feed into a pipe, they then have their own separate code for feeding in that saved wav into the audio subsystem themselves (usually via gstreamer as far as I can tell). It's quite a lot of swings and roundabouts!

comment:5 in reply to: ↑ 4 Changed 9 years ago by mavrothal

Replying to garycmartin:

If you run top in Terminal after the clock fails to speak you will see the hung espeak process ticking away, this is what is causing the subsequent issue. If you killall espeak, and then resume Clock activity the face will correctly draw.

That's right!

I find espeak run from the terminal will lock up just the same after a hand full of trys, either part way through speach, or at the end of speech, just like from Clock.

Well, I tried espeak with "this is a nice little machine but very underpowered" on the XO-1/F14/os22, 10 times and proved me wrong :-)
Though once it did lock on "hello"!...

comment:6 Changed 9 years ago by tonyforster

clock 5 and 6 not speaking in the au build
https://dev.laptop.org.au/issues/802
Sugar 0.84

clock6 is ok in sugar 0.88 373pyg

comment:7 Changed 9 years ago by sridhar

  • Cc sridhar added

comment:8 Changed 9 years ago by RafaelOrtiz

  • Cc RafaelOrtiz added

comment:9 Changed 9 years ago by RafaelOrtiz

This is confirmed working on newer os builds, at least.

http://dev.laptop.org/ticket/11266

comment:10 Changed 8 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from accepted to closed

fixed as per comment above.

Note: See TracTickets for help on using tickets.