Opened 11 years ago

Closed 11 years ago

#1564 closed defect (fixed)

Failure when chcking out turtleart

Reported by: HoboPrimate Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

I get this error during the update phase of sugar-jhbuild:

* Checking out turtleart * [38/41]
git stash save jhbuild-stash
locale/nb/activity.linfo: needs merge
locale/nb/activity.linfo: needs merge
locale/nb/activity.linfo: unmerged (0b2ef7cc7563f23d7bfab7bdc80bc35e410a7ad0)
locale/nb/activity.linfo: unmerged (e1999f46d9b33c8a60e9da3b2042338ae63d49c6)
fatal: git-write-tree: error building trees
Cannot save the current index state
* Error during phase checkout of turtleart: ########## Error running git stash save jhbuild-stash * [38/41]

I'm running Ubuntu 9.10.

Change History (5)

comment:1 Changed 11 years ago by walter

I've seen this before and don't recall the root cause, but I just did a genpot and a push and I am able to successfully run ./sugar-jhbuild update turtleart. Can you please try again? (and mybe try a ./sugar-jhbuild clean turtleart ?

comment:2 Changed 11 years ago by HoboPrimate

I tried both commands, and the error still occurs.

comment:3 Changed 11 years ago by walter

Maybe try rm -rf source/turtleart before doing your update and build? I cannot reproduce the on a 9.10 system.

comment:4 Changed 11 years ago by HoboPrimate

Just did that, and it now updates fine. Thanks for fixing my problem :)

Eduardo

comment:5 Changed 11 years ago by walter

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.