Opened 11 years ago

Closed 11 years ago

#1557 closed defect (fixed)

Moving tiles in TurtleArt let a trace on the screen

Reported by: sayamindu Owned by: walter
Priority: Normal Milestone: Unspecified
Component: Turtleart Version: Unspecified
Severity: Minor Keywords:
Cc: Distribution/OS: OLPC
Bug Status: New

Description

From http://dev.laptop.org/ticket/9678:

In TurtleArt, moving tiles with number (forward, left, ...) let a trace on the screen. The trace disappear when the screen is refreshed. It seems that the font size used for number is too large.

It seems that changing the default font-size helps.

diff --git a/tasprites.py b/tasprites.py
index 7065b16..56da3a1 100644
--- a/tasprites.py
+++ b/tasprites.py
@@ -157,7 +157,7 @@ def draw_label(spr, label, myscale, center_flag, truncate_flag):
 
 # used for most things
 def draw_label1(spr, label):
-    draw_label(spr, label, 7, True, True)
+    draw_label(spr, label, 6, True, True)
 
 # used for status blocks
 def draw_label2(spr, label):

Change History (4)

comment:1 Changed 11 years ago by RafaelOrtiz

  • Bug Status changed from Unconfirmed to New
  • Priority changed from Unspecified by Maintainer to Normal
  • Severity changed from Unspecified to Minor

comment:2 Changed 11 years ago by walter

  • Resolution set to wontfix
  • Status changed from new to closed

As I pointed out in http://dev.laptop.org/ticket/9678, this seems to be an artifact of a general font-scaling problem on the OLPC XO 1.5. It doesn't make sense to try to address it in individual activities.

comment:3 Changed 11 years ago by walter

  • Resolution wontfix deleted
  • Status changed from closed to reopened

Turns out the "system-wide" font scaling problem was not the problem after all. The way I was detecting XO hardware no longer worked on the XO 1.5 machine so I was applying the non-XO font scaling to XO. I now (as of v79) use /etc/olpc-release to detect XO hardware and the problem should be fixed.

comment:4 Changed 11 years ago by walter

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.