Opened 12 years ago

Closed 10 years ago

Last modified 8 years ago

#155 closed defect (fixed)

TurtleArtwithSensors has different requirements for non-XO hardware

Reported by: walter Owned by: walter
Priority: Normal Milestone:
Component: Turtleart Version: Unspecified
Severity: Minor Keywords:
Cc: sascha_silbe, sayamindu Distribution/OS: Unspecified
Bug Status: Assigned

Description

On Ubuntu, using sugar-jhbuild, TA with Sensors fails to launch due to missing moduke alsaaudio imported by audiograb.py

Change History (12)

comment:1 Changed 12 years ago by walter

the python-alsaaudio module (alsaaudio.so) perhaps should be in the build, but there is a follow up problem for non-XO machines. There seems to be a mode that was added for the XO mic in:

File "/home/walter/Activities/TurtleArtwithSensors.activity/talogo.py", line 3

24, in doevalstep

if not lc.step.next(): stopsignoff(lc); return False

File "/home/walter/Activities/TurtleArtwithSensors.activity/talogo.py", line 1

36, in evalsym

else: result = lc.cfun.fcn(lc, *lc.arglist)

File "/home/walter/Activities/TurtleArtwithSensors.activity/talogo.py", line 2

49, in <lambda>

defprim(lc,'sensor_val0', 0, lambda lc: sensor_val(lc, 0))

File "/home/walter/Activities/TurtleArtwithSensors.activity/talogo.py", line 3

68, in sensor_val

ag = AudioGrab()

File "/home/walter/Activities/TurtleArtwithSensors.activity/audiograb.py", lin

e 47, in init

self.dcmode = Mixer('DC Mode Enable')

comment:2 Changed 12 years ago by walter

  • Status changed from new to accepted

I suppose I should be adding alsaaudio module to the bundle. There are numerous other problems with audio that need to be fixed: perhaps this can become a collector ticket for them all:

  1. alsaaudio module required
  2. pitch doesn't work due to missing real_fft module
  3. audio is turned on and off with each sample. It should be left on while a stack is running and TA should detect when it is put into the background in order to free up the device.
  4. resistance and voltage blocks should be disabled on non-OLPC-XO-1 machines.

comment:3 Changed 12 years ago by gregdek

  • Bug Status set to Assigned
  • Distribution/OS set to Unspecified
  • Milestone set to 0.86
  • Severity set to Minor
  • Summary changed from TurtleArtwithSensors requires alsaaudio module to TurtleArtwithSensors has different requirements for non-XO hardware

Moving out to the 0.86 release.

comment:4 Changed 12 years ago by erikos

The problem is, if you add it to the bundle it will break on different architectures - 64bit etc. Is this functionality not available upstream?

comment:5 Changed 12 years ago by walter

The OLPC-specific needs are not upstream (and I cannot imagine they will ever be accepted upstream), so the inclusion of the binary is for OLPC, not other distros.

comment:6 Changed 12 years ago by sascha_silbe

  • Cc sascha_silbe added

comment:7 Changed 12 years ago by sayamindu

  • Cc sayamindu added

comment:8 Changed 12 years ago by walter

  • Milestone changed from 0.86 to 0.88
  • Priority changed from minor to Normal

comment:9 Changed 11 years ago by walter

  • Milestone changed from 0.88 to 0.90

Will resolve in context of 0Install work.

comment:10 Changed 10 years ago by walter

Well, with the work Sascha did on Measure's amixer controls, I managed to rework the audio grab for TA with sensors to no longer have any alsaaudio dependencies. #2035 is relevant to TA as well.

comment:11 Changed 10 years ago by walter

  • Resolution set to fixed
  • Status changed from accepted to closed

comment:12 Changed 8 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.