Opened 11 years ago

Closed 11 years ago

#1531 closed defect (fixed)

sugar-jhbuild fails to start, "cannot import name emulator"

Reported by: HoboPrimate Owned by: sascha_silbe
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: sugar-jhbuild Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

Using sugar-jhbuild on latest ubuntu, when running it, it fails with the error message:

Traceback (most recent call last):

File "<string>", line 1, in <module>

ImportError: cannot import name emulator

This happened when I updated yesterday from a month old sugar-jhbuild, and it still happens with both updates I did today.

Change History (4)

comment:1 Changed 11 years ago by wadeb

This happened to me once; it was because I failed to build and install all of jhbuild. The module you speak of, emulator, was a recent addition.

Make sure that the update ran cleanly against all your repositories (e.g. you don't have any files modified locally).

comment:2 Changed 11 years ago by wadeb

My bad; an IRC conversation reminded me the real fix for this issue. Since there is a new file, jhbuild needs to re-run autoconf to update the various Makefiles.

The following command will build everything, including the autoconf step.

./sugar-jhbuild build -a

comment:3 Changed 11 years ago by HoboPrimate

Thanks, that fixed it. Should this ticket remain open, in case other people have the same problem and can find the solution here?

comment:4 Changed 11 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from new to closed

We can close it as fixed, because in doing so the information wont disappear.

Note: See TracTickets for help on using tickets.