Opened 10 years ago

Closed 6 years ago

#1520 closed defect (wontfix)

alt-tab should do nothing when only the journal is running

Reported by: mtd Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: sugar-love
Cc: mtd, smparrish Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

If only the Journal - and no other activities - is running, alt-tab should do nothing.

Currently, it shows the frame and switches to the journal, and then keeps switching to it (which looks to the user just like the frame is getting revealed and hidden for each Alt+Tab press).

Releated to #1518 .

Change History (7)

comment:1 Changed 9 years ago by mtd

  • Keywords sugar-love added

comment:2 follow-up: Changed 9 years ago by fran

The current behavior is basically equivalent to what GNOME does; in GNOME, if you have a single window open, it still brings up the usual Alt-Tab dialog. (And it's not always a no-op, since that window might be minimized; in the case of Sugar, they might be in the Activity/Group/Neighborhood view) I'd be inclined to say this is the proper behavior; a user pressing Alt-Tab may have forgotten they have only the Journal open, and it's useful for the frame with its list of activities to appear and remind them of this.

comment:3 in reply to: ↑ 2 Changed 9 years ago by sascha_silbe

Replying to fran:

The current behavior is basically equivalent to what GNOME does; in GNOME, if you have a single window open, it still brings up the usual Alt-Tab dialog. (And it's not always a no-op, since that window might be minimized; in the case of Sugar, they might be in the Activity/Group/Neighborhood view) I'd be inclined to say this is the proper behavior; a user pressing Alt-Tab may have forgotten they have only the Journal open, and it's useful for the frame with its list of activities to appear and remind them of this.

+1
Having Alt-Tab do nothing just makes it appear broken.

comment:4 Changed 9 years ago by smparrish

  • Cc smparrish added

IMO this is the correct behavior and am inclined to just close this one.

comment:5 Changed 9 years ago by mtd

The current behaviour - showing the Frame, which is not a window/task switching UI element - is not at all the same as GNOME showing the window/task switching UI. There is no indication the one has started switching tasks but that there is only one task to switch to. I agree that if the user did get visual feedback they had started the task switching the behaviour, it would be acceptable.

comment:6 Changed 9 years ago by smparrish

  • seeta_dev set to Mukul

comment:7 Changed 6 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.