Opened 11 years ago

Closed 10 years ago

#1516 closed defect (fixed)

Quiz-3 Activity does not launch on F11 (XO) platform

Reported by: mikus Owned by: RafaelOrtiz
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: ActivityTeam Version: 0.84.x
Severity: Unspecified Keywords: r?
Cc: mikus@…, alsroot Distribution/OS: OLPC
Bug Status: Unconfirmed

Description

On XO-1.5 with Sugar 0.84, Quiz-3 Activity fails to launch because of invalid import code. [Same problem if running on XO-1]

Attachments (4)

Quiz.log (1.7 KB) - added by mikus 11 years ago.
Quiz.2.log (1.6 KB) - added by mikus 10 years ago.
XO-1 build os1 (F14) with sugar 0.89.8 -- Quiz-3 output - same problem
org.laptop.Quiz-4.log (1.1 KB) - added by RafaelOrtiz 10 years ago.
0001-Import-plugins-as-modules-not-as-files.patch (895 bytes) - added by alsroot 10 years ago.

Download all attachments as: .zip

Change History (10)

Changed 11 years ago by mikus

Changed 10 years ago by mikus

XO-1 build os1 (F14) with sugar 0.89.8 -- Quiz-3 output - same problem

comment:1 Changed 10 years ago by RafaelOrtiz

  • Owner changed from garycmartin to RafaelOrtiz
  • Status changed from new to assigned

Also failling with XO-1.5 sugar 0.88/0.90

comment:2 Changed 10 years ago by RafaelOrtiz

Fixed import error but IPYTHON error arises (attached)


Changed 10 years ago by RafaelOrtiz

comment:3 Changed 10 years ago by RafaelOrtiz

ideas welcomed.

comment:4 Changed 10 years ago by alsroot

  • Cc alsroot added
  • Keywords r? added

The problem is that plugins are being imported as files, that doesn't work.

comment:5 Changed 10 years ago by RafaelOrtiz

Fixed in V4 of quiz.

comment:6 Changed 10 years ago by RafaelOrtiz

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.