Opened 12 years ago

Closed 12 years ago

Last modified 8 years ago

#1480 closed defect (notabug)

datastore/journal suffering from Alzheimer's disease

Reported by: walter Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

I am running a relatively recent jhbuild environment (last updated about 10 days ago). Today, suddenly my journal lost its memory of everything I've done for at least the past month. Not sure why. Logs attached.

Note that I have a very large journal.

Attachments (10)

datastore.log (234.9 KB) - added by walter 12 years ago.
current log
shell.log (29.2 KB) - added by walter 12 years ago.
current shell
datastore.2.log (181.4 KB) - added by walter 12 years ago.
prev log 1
shell.2.log (29.5 KB) - added by walter 12 years ago.
prev shell 1
datastore.3.log (170.0 KB) - added by walter 12 years ago.
prev log 2
shell.3.log (21.8 KB) - added by walter 12 years ago.
prev shell 2
datastore.4.log (188.8 KB) - added by walter 12 years ago.
prev log 3
shell.4.log (21.5 KB) - added by walter 12 years ago.
prev shell 3
datastore.5.log (234.2 KB) - added by walter 12 years ago.
prev log 4
shell.5.log (28.0 KB) - added by walter 12 years ago.
prev shell 4

Download all attachments as: .zip

Change History (12)

Changed 12 years ago by walter

current log

Changed 12 years ago by walter

current shell

Changed 12 years ago by walter

prev log 1

Changed 12 years ago by walter

prev shell 1

Changed 12 years ago by walter

prev log 2

Changed 12 years ago by walter

prev shell 2

Changed 12 years ago by walter

prev log 3

Changed 12 years ago by walter

prev shell 3

Changed 12 years ago by walter

prev log 4

Changed 12 years ago by walter

prev shell 4

comment:1 Changed 12 years ago by walter

  • Resolution set to notabug
  • Status changed from new to closed

Apparently the disease is caused by too many Turtle Art projects (~1500) which slows down the index update to such an extent that occasionally it fall behind. Patience was a virtue in this case. Problem resolved itself.

We may want to document this beyond the developer notes somewhere.

comment:2 Changed 8 years ago by dnarvaez

  • Component changed from sugar-datastore to Sugar
Note: See TracTickets for help on using tickets.