Opened 12 years ago

Closed 8 years ago

Last modified 8 years ago

#1475 closed task (wontfix)

toggle fullscreen keybinfdings got lost

Reported by: erikos Owned by: tomeu
Priority: Immediate Milestone:
Component: Sugar Version: 0.85.x
Severity: Blocker Keywords: relnote
Cc: sayamindu, eben, garycmartin Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

We used to have 'alt+return' to toggle fullscreen mode. Did we have a discussion why we changed it to use 'esc' to escape it? Sorry if I just forgot about it.

We have to announce that change at least in the release notes.

The terminal activity has to remove the accelerator.

Change History (8)

comment:1 in reply to: ↑ description Changed 12 years ago by garycmartin

Replying to erikos:

We used to have 'alt+return' to toggle fullscreen mode. Did we have a discussion why we changed it to use 'esc' to escape it? Sorry if I just forgot about it.

I missed that one as well. Alt+enter should be the global system toggle in and out of fullscreen otherwise esc becomes another key stroke activity authors will have to avoid using (Terminal and I think Labyrinth would be effected if esc key events are used).

comment:2 Changed 12 years ago by eben

Hmm, I disagree. Escape is used almost universally as a way to exit fullscreen mode. While I think the alt-enter shortcut that got you there should also exit the mode, I support the use of the escape shortcut solely for exiting (never, of course, entering) fullscreen mode.

comment:3 Changed 12 years ago by erikos

  • Priority changed from High to Immediate
  • Severity changed from Major to Blocker
  • Summary changed from accelerator to escape from fullscreen to toggle fullscreen keybinfdings got lost

Ok, we had the 'esc' in sugar to escape fullscreen for nearly 2 years, I just forgot about it, since I always used alt+enter. We defined it before in the macthbox keybindings.

To get it back we need to either define it in metacity or in the sugar keybindings.

comment:4 Changed 12 years ago by sayamindu

I'm a bit confused here, but just wanted to mention that historically, fiddling around with Terminal shortcuts have resulted in people getting really annoyed, as most of the time, I have ended up breaking their favourite command line application :-).

comment:5 Changed 12 years ago by wadeb

See also #440, #475.

comment:6 Changed 11 years ago by RafaelOrtiz

  • Milestone changed from 0.86 to 0.88.x

comment:7 Changed 8 years ago by dnarvaez

  • Resolution set to wontfix
  • Status changed from new to closed

If this has gone unfixed for 4 years...

comment:8 Changed 8 years ago by dnarvaez

  • Milestone 0.88.x deleted

Milestone 0.88.x deleted

Note: See TracTickets for help on using tickets.