Opened 11 years ago

Closed 10 years ago

#1446 closed defect (obsolete)

Calculator error should be more readable, better error parsing should be implemented

Reported by: mvadkert Owned by: rwh
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Calculate Version: Unspecified
Severity: Major Keywords:
Cc: smparrish@… Distribution/OS: Fedora
Bug Status: Unconfirmed

Description

Description of problem:
If you start calculator activity and hit several times Enter, you get an error:

Error at 0: Parse error

Version-Release number of selected component (if applicable):
0.85.4-1

How reproducible:
always

Steps to Reproduce:

  1. start calculator activity
  2. hit Enter button several times
  3. observe output

Actual results:
Error at 0: Parse error

Expected results:
No error, blank screen.

Additional info:
Also the input filtering could be better, try to enter a very long number and
hit Enter -> the screen gets mixed up. See attached screenshot.

Attachments (1)

calculate_mixed_up_screen.png (26.7 KB) - added by mvadkert 11 years ago.
mixed up screen after a long input in calculator

Download all attachments as: .zip

Change History (3)

Changed 11 years ago by mvadkert

mixed up screen after a long input in calculator

comment:1 Changed 11 years ago by mvadkert

This bug was found during F12 test day - Sugar on a stick, and reported to RedHat bugzilla https://bugzilla.redhat.com/show_bug.cgi?id=521073

comment:2 Changed 10 years ago by garycmartin

  • Resolution set to obsolete
  • Status changed from new to closed

Testing in Calculate-31 I can't reproduce the 'hit several times Enter, you get an error' issue, and the 'mixed up screen after a long input in calculator' item was an issue during Sugar's the transition from Matchbox to Metacity. It affected several other activities and was fixed in Sugar some time back.

Note: See TracTickets for help on using tickets.