Opened 11 years ago

Closed 11 years ago

Last modified 7 years ago

#1444 closed defect (fixed)

Activities tray doesn't reflect well on switching between windows if there are non-sugar ones

Reported by: alsroot Owned by: tomeu
Priority: Immediate Milestone:
Component: Sugar Version: 0.85.x
Severity: Blocker Keywords: r+
Cc: Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

|TestCase|

  • open two non-sugar X programs
  • make them visible at the same time
  • switch between them by clicking on windows(not in activity tray)
  • activities tray doesn't reflect correct of this switching(it shows the same active window all time)

Attachments (2)

sugar-1444.patch (1.6 KB) - added by alsroot 11 years ago.
sugar-1444.2.patch (2.2 KB) - added by alsroot 11 years ago.

Download all attachments as: .zip

Change History (11)

comment:1 in reply to: ↑ description Changed 11 years ago by alsroot

Replying to alsroot:

|TestCase|

  • open two non-sugar X programs

in Terminal

  • make them visible at the same time
  • switch between them by clicking on windows(not in activity tray)
  • activities tray doesn't reflect correct of this switching(it shows the same active window all time)

Changed 11 years ago by alsroot

comment:2 Changed 11 years ago by alsroot

  • Keywords r? added

The problem is, for all windows(model.shell.Activity) that are created from Terminal we have the same activity_id, not sure maybe thats another issue, but anyway since we create button in activity tray per model.shell.Activity object, it could be more straightforward to use object itself for buttons dictionary rather then activity_id.

comment:3 Changed 11 years ago by alsroot

  • Resolution set to fixed
  • Status changed from new to closed

new patch was reviewed by tomeu on #sugar
http://git.sugarlabs.org/projects/sugar/repos/mainline/commits/8c8f8c6d3f669bd7f5e5c95b31ae1f6d6d3b494a

The same activity_id issue for all non-sugar windows was moved to #1456.

comment:4 Changed 11 years ago by alsroot

  • Resolution fixed deleted
  • Status changed from closed to reopened

Commited patch doesn't cover all situations, there could be situation then dbus shell method NotifyLaunch() will be invoked before activity window appeared, so activitiestray.activity_added_cb will use None key for created button.

Changed 11 years ago by alsroot

comment:5 Changed 11 years ago by alsroot

  • Milestone changed from Unspecified by Release Team to 0.86
  • Priority changed from Unspecified by Maintainer to Immediate
  • Severity changed from Unspecified to Blocker

comment:7 Changed 11 years ago by erikos

This one is important, as in 0.86.1 closing activities is broken. We need testing of the bug fixes we land. To give a good example, I applied the fix from above on 9.04 Ubuntu 0.86.1 and it works fine :)

Thanks for the fix!

comment:8 Changed 11 years ago by erikos

  • Keywords r+ added; r? removed

comment:9 Changed 7 years ago by dnarvaez

  • Milestone 0.86 deleted

Milestone 0.86 deleted

Note: See TracTickets for help on using tickets.