Opened 10 years ago

Closed 6 years ago

Last modified 6 years ago

#1439 closed enhancement (obsolete)

Report a problem control panel

Reported by: wadeb Owned by: wadeb
Priority: Normal Milestone:
Component: Sugar Version: Unspecified
Severity: Unspecified Keywords: r!
Cc: bernie Distribution/OS: Unspecified
Bug Status: Unconfirmed

Description

This ticket holds the patch files and server script for http://wiki.sugarlabs.org/go/Features/Problem_Reports.

Attachments (4)

0001-Option-1-not-working-Upload-logs-button-displays.patch (22.9 KB) - added by wadeb 10 years ago.
Option 1 for Log activity (doesn't work): Bring up control panel when the Upload logs button is clicked.
0001-Option-2-Remove-Upload-logs-button-entirely.patch (22.2 KB) - added by wadeb 10 years ago.
Option 2 for Log activity: Remove Upload logs button entirely.
0001-New-control-panel-Report-a-problem.patch (38.6 KB) - added by wadeb 10 years ago.
Initial patch
logcollect-server.php (4.5 KB) - added by wadeb 10 years ago.
latest server

Download all attachments as: .zip

Change History (13)

Changed 10 years ago by wadeb

Option 1 for Log activity (doesn't work): Bring up control panel when the Upload logs button is clicked.

Changed 10 years ago by wadeb

Option 2 for Log activity: Remove Upload logs button entirely.

comment:1 Changed 10 years ago by wadeb

  • Owner changed from tomeu to wadeb
  • Status changed from new to accepted

comment:2 Changed 10 years ago by wadeb

Server script updated to use PDO API which is installed on sunjammer.

Changed 10 years ago by wadeb

Initial patch

comment:3 Changed 10 years ago by wadeb

  • Keywords r? added

The patch has been updated:
The log server is now stored in Gconf; default is logcollect.sugarlabs.org.
If the upload fails, the log is copied to the journal.
Bug fixes and cleanups to log collecting.
New icon from Gary C. Martin.

Patch is now ready for feedback.

Changed 10 years ago by wadeb

latest server

comment:5 Changed 10 years ago by tomeu

  • Keywords r! added; r? removed

logcollect.py uses a style different from the rest of Sugar, can you modify it according to http://wiki.sugarlabs.org/go/Development_Team/Code_guidelines ?

+def save_logs_to_journal(archive_name):

Should be private?

+    ds = datastore.create()

jobject is more common, grepping the sources helps to find consistent names

+    ds.metadata['title'] = archive_name
+    ds.metadata['mime_type'] = 'application/zip'

I'm a bit concerned about users not being able to relate these entries to bug reports. Can we have a more descriptive title? And maybe the insect icon?

+    del ds

Not needed.

+    _logger.debug('Saving %s to the journal.' % archive_name)

Better avoid using % in debug messages because of performance.

+        _logger.debug('Failed to collect logs:\n%s\n', e)

Better use _logger.exception so we don't lose information about the exception

+        if server[:7] != 'http://':
+            server = 'http://' + server + '/'

Won't be prepending http:// to an url that starts with https://?

+        # When the upload fails, fall back to saving the logs to the Journal.

Isn't this superfluous given the surrounding code?

+            _logger.debug('Failed to save logs to journal:\n%s\n', e)

Should be _logger.exception() instead?

+        description_label = gtk.Label(_('Please describe the problem you encountered.'))

Should this be about problems or could be more general?

comment:6 Changed 9 years ago by walter

  • Milestone changed from 0.88 to 0.90

Seems to be some unanswered questions post review. Moving to 0.90

comment:7 Changed 9 years ago by bernie

  • Cc bernie added

It would be great if we could have this feature. Is anyone pushing it?

comment:8 Changed 6 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from accepted to closed

Sadly obsolete patches.

comment:9 Changed 6 years ago by dnarvaez

  • Milestone 0.90 deleted

Milestone 0.90 deleted

Note: See TracTickets for help on using tickets.