Opened 11 years ago

Closed 8 years ago

#1418 closed defect (notsugar)

inkscape crashes Sugar

Reported by: walter Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

Used to work fine in 0.84. In 0.86, it launches, but as soon as the window get focus, Sugar crashes.

to reproduce:

  1. open a Terminal
  2. run inkscape
  3. click in the inkscape canvas.

Sugar crashes. Console output here:

./sugar-jhbuild run sugar-emulator --dimension 1200x900
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
(EE) XKB: No components provided for device Virtual core keyboard
[config/dbus] couldn't register object path
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
1253646909.9517391 STARTUP: Starting the shell
Window manager warning: 0 stored in GConf key /desktop/gnome/peripherals/mouse/cursor_size is out of range 1 to 128

(sugar-session:11552): WARNING : Trying to register gtype 'XklEngineFeatures' as flags when in fact it is of type 'GEnum'
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x800003 (sugar-sess)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

Backtrace (8 deep):
0: Xephyr(KdBacktrace+0x35) [0x80c1595]
1: [0xb8012400]
2: Xephyr(ProcXGrabDevice+0x12a) [0x8195a0a]
3: Xephyr [0x81924e3]
4: Xephyr(Dispatch+0x33f) [0x80b356f]
5: Xephyr(main+0x3bd) [0x809869d]
6: /lib/tls/i686/cmov/libc.so.6(libc_start_main+0xe5) [0xb7a7f775]
7: Xephyr [0x8070741]

Fatal server error:
Segmentation fault caught

Window manager warning: Fatal IO error 11 (Resource temporarily unavailable) on display ':100'.
walter@walter-laptop:~/sugar-jhbuild$

Change History (7)

comment:1 Changed 11 years ago by walter

Note that you can access the menus and resize the window. It is just accessing the canvas that causes the segfault.

comment:2 Changed 11 years ago by walter

Same behavior with the Gimp. Menus work, but touching the canvas causes a segfault.

comment:3 Changed 11 years ago by walter

Checked out a few more activities: gedit and mahjongg work fine.

comment:4 Changed 11 years ago by walter

and no problem with the unsugarized tuxpaint...
/me wonders if the unmodified gcompris activities would run OK (re #1417)

comment:5 Changed 11 years ago by sascha_silbe

It's Xephyr that crashed. I don't think there's anything we can do about that, I'm afraid.
Would be great if you could test with the vnc-using sugar-emulator instead, though.

comment:6 Changed 11 years ago by tomeu

Well, we could get a good backtrace and pass it upstream. Though I cannot reproduce it in F11, both Gimp and Inkscape work fine.

Would be good to check if the same traceback is reported in ubuntu's launchpad.

comment:7 Changed 8 years ago by dnarvaez

  • Resolution set to notsugar
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.