Opened 11 years ago

Closed 11 years ago

#1417 closed defect (fixed)

GCompris activities don't work with 0.86 Metacity changes

Reported by: walter Owned by: alsroot
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: ActivityTeam Version: 0.85.x
Severity: Unspecified Keywords:
Cc: bruno.coudoin@… Distribution/OS: Ubuntu
Bug Status: Unconfirmed

Description

Launching GCompris activities result in only partially rendered windows (See the attached image of Sudoku).

Filing under Sugar because there is no GCompris component and it seems to be an issue with the transition to 0.86.

The console output from jhbuild is below:

./sugar-jhbuild run sugar-emulator --dimension 1200x900
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
[dix] Could not init font path element /usr/share/fonts/X11/cyrillic, removing from list!
(EE) XKB: No components provided for device Virtual core keyboard
[config/dbus] couldn't register object path
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
unrecognised device identifier!
(EE) config/hal: NewInputDeviceRequest failed (2)
1253646909.9517391 STARTUP: Starting the shell
Window manager warning: 0 stored in GConf key /desktop/gnome/peripherals/mouse/cursor_size is out of range 1 to 128

(sugar-session:11552): WARNING : Trying to register gtype 'XklEngineFeatures' as flags when in fact it is of type 'GEnum'
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x800003 (sugar-sess)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

Attachments (1)

sudoku-0.86.png (5.3 KB) - added by walter 11 years ago.

Download all attachments as: .zip

Change History (6)

Changed 11 years ago by walter

comment:1 follow-up: Changed 11 years ago by garycmartin

FWIW: Just tested a selection of GCompris activities under F11 sugar-jhbuild and all were rendering correctly (sudoku, chess computer, algebra, geography, hexagon, paratrooper, billard, bargame, tangram)

comment:2 in reply to: ↑ 1 Changed 11 years ago by tomeu

Replying to garycmartin:

FWIW: Just tested a selection of GCompris activities under F11 sugar-jhbuild and all were rendering correctly (sudoku, chess computer, algebra, geography, hexagon, paratrooper, billard, bargame, tangram)

I guess there's some race setting the X properties, I have seen three behaviors:

  • activity opens fullscreen, without decorations,
  • activity opens smaller, without decorations,
  • activity opens smaller, with decorations

I'm digging further, right now.

comment:3 Changed 11 years ago by tomeu

  • Cc bruno.coudoin@… added

The problem seems to be that GCompris activities set on the decorations themselves:

http://git.gnome.org/cgit/gcompris/tree/src/gcompris/gcompris.c?h=gcomprixogoo#n1045

Maybe the fullscreen stuff can be deactivated when running on Sugar?

comment:4 Changed 11 years ago by alsroot

  • Component changed from sugar to ActivityTeam
  • Owner changed from tomeu to alsroot
  • Status changed from new to assigned
  • Version changed from Git as of bugdate to 0.85.x

comment:5 Changed 11 years ago by alsroot

  • Resolution set to fixed
  • Status changed from assigned to closed

fixed in last GCompris versions

Note: See TracTickets for help on using tickets.