Opened 12 years ago

Closed 8 years ago

#1405 closed defect (obsolete)

should we catch the KeyError in controlpanel/gui.py?

Reported by: walter Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: 0.85.x
Severity: Unspecified Keywords: controlpanel
Cc: Distribution/OS: Ubuntu
Bug Status: Needinfo

Description (last modified by sascha_silbe)

If there is no xklavier module installed there is a KeyError in jarabe/controlpanel.py

        try:
            import xklavier
        except ImportError:
            del self._options['keyboard']

self._options doesn't always seem to have a 'keyboard' entry.

Change History (6)

comment:1 Changed 12 years ago by alsroot

  • Bug Status changed from Unconfirmed to Needinfo

But keyboard component has been loaded anyway(despite of having xklavier), so we need to remove proper control component.
I tested it in my env(last git) with and without xklavier and didn't get error, could you reproduce this issue with last versions.

comment:2 Changed 12 years ago by walter

Perhaps I have a bad build. I'll do a clean install to see if the problem persists. But that key did not exist on sugar-jhbuild on Ubunutu.

comment:3 Changed 12 years ago by sascha_silbe

  • Description modified (diff)

comment:4 Changed 12 years ago by walter

The problem seems to have gone away with a clean build--because import xklavier is now successful. When I force the ImportError, I still have the problem with KeyError. I am not sure why the key is missing, but if we trap the error, then the control panel still opens. Otherwise it does not.

comment:5 Changed 11 years ago by walter

  • Type changed from enhancement to defect

comment:6 Changed 8 years ago by dnarvaez

  • Resolution set to obsolete
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.