Opened 12 years ago

Closed 8 years ago

#1383 closed defect (fixed)

Strange error while using object chooser

Reported by: kushal Owned by: tomeu
Priority: Unspecified by Maintainer Milestone: Unspecified
Component: Sugar Version: Git as of bugdate
Severity: Unspecified Keywords:
Cc: Distribution/OS: Fedora
Bug Status: Needinfo

Description

I am trying to access some media files from a pendrive. The following error is coming (from jukebox log)

1253216581.054341 WARNING root: Invocation of ObjectChooser() has deprecated parameters.
/usr/lib/python2.6/site-packages/dbus/connection.py:242: DeprecationWarning: object.init() takes no parameters

super(Connection, self).init(*args, kwargs)

1253216583.901034 DEBUG root: ObjectChooser.chooser_response_cb: dbus.String(u'/media/FEDORA/m.mp3')
1253216583.953487 DEBUG root: datastore.get
Traceback (most recent call last):

File "/junk/git/sugar-jhbuild2/install/share/sugar/activities/Jukebox.activity/jukeboxactivity.py", line 257, in _show_picker_cb

if jobject and jobject.file_path:

File "/junk/git/sugar-jhbuild2/install/lib/python2.6/site-packages/sugar/datastore/datastore.py", line 177, in get_file_path

os.symlink(self.object_id, self._file_path)

OSError: [Errno 2] No such file or directory
1253216587.936109 WARNING root: RawObject was deleted without cleaning up. Call RawObject.destroy() before disposing it.
Exception OSError: (2, 'No such file or directory', '/home/kdas/.sugar/default/data/rawobjectlR7wFY') in <bound method RawObject.del of <sugar.datastore.datastore.RawObject object at 0x8a04d4c>> ignored

Change History (3)

comment:1 Changed 12 years ago by alsroot

  • Bug Status changed from Unconfirmed to Needinfo

What sugar version you are using?

Similar issue was fixed recently and I can't reproduce it(open .ogg from usb stick and it plays fine).

comment:2 Changed 8 years ago by dnarvaez

  • Component changed from sugar-datastore to Sugar

comment:3 Changed 8 years ago by dnarvaez

  • Resolution set to fixed
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.